Benutzername    Passwort    Autologin    
  Passwort vergessen       Registrieren  
beeForum Foren-übersicht » hal9000 » mod support
Neues Thema eröffnen   Neue Antwort erstellen Hervorhebung entfernen


Installation problems
Vorheriges Thema anzeigen :: Nächstes Thema anzeigen  
Autor Nachricht
LSBMaster





Titel: Installation problems
Verfasst am: Mo, 15 Mai 2006, 03:10
Beitrag
Antworten mit Zitat

Hello, I am trying to install v. 1.3.2. I've successfully edited and uploaded all the files, then I disable the board and run the installer. What I see is a message saying 'We're sorry, this board is currently disabled", and a few of the images from my board (anything with an absolute path). The message is the standard message displayed when the board is disabled, however, it does indicate that I'm logged in as administrator. The configuration menu I expect to see isn't there (I installed this on another site about a year ago, so I know basically what to expect).

If I try to enable the board and run the install, I get the "Please make sure the install and contrib directories are deleted" (as I would expect to).

I'm running version phpBB 2.0.20 with no mods. I'm on a Linux server (with 1and1.com).

I'm guessing there's something wrong with the paths or something. The install file has this:

Code:

define('IN_PHPBB', true);
$phpbb_root_path = '../';
include($phpbb_root_path . 'extension.inc');
include($phpbb_root_path . 'common.'.$phpEx);
$gen_simple_header = true;


That looks OK - I'm running the installer from the "Install" directory.

Any suggestions? Thanks!

Nach oben
Rang:
boris



Beiträge: 10136

Titel: (Kein Titel)
Verfasst am: Mo, 15 Mai 2006, 20:32
Beitrag
Antworten mit Zitat

Are your sure you called the install-file directly instead of just pointing your browser to the install-directory ?

I do it like this and it works:
1. do not disable your board
2. log in on your admin-account
3. upload the install-directory
4. call the install-script with your browser:
something like this: yourdomain.com/yourforumpath/install/install_uploadpic.php

Works fine for me for all phpBB-versions (since 2.0.17) ...


____________
beehave - home of humbug ... [we can't afford to be neutral]

Nach oben
Private Nachricht senden Website dieses Benutzers besuchen Rang:godmode methusalem 3. platz professioneller Sportangler Profi-Winzer (7x Hamm) Arcade-Meister, Rang 16 rainbow-cup
LSBMaster





Titel: (Kein Titel)
Verfasst am: Mo, 15 Mai 2006, 23:42
Beitrag
Antworten mit Zitat

OK, I think the problem was with Firefox. When I tried running the install in IE, it worked fine. Firefox has always seemed a little bit flaky in the way in handles PHPBB cookies. So, anyway, the install has been successful.

Now, when I try to actually upload a pic, I get the error:

"The datatype image/jpeg is not supported"

In the Upload Pic Admin section, I have the following datatypes allowed:

jpg, jpeg, bmp, gif

Just like that - seperated by commas. I tried no commas, too. Neither seems to work. I also tried gif files, not just jpg files, and got the same error. Any ideas on that?

Nach oben
Rang:
LSBMaster





Titel: (Kein Titel)
Verfasst am: Mo, 15 Mai 2006, 23:52
Beitrag
Antworten mit Zitat

OK, I figured that out. For anyone who cares, the syntax should be:

Code:
image/jpg|image/jpeg|image/pjpeg|image/gif|image/png|image/x-png


Exactly like that, with the pipe symbols and everything, in the "Image Type Supported" field.

So far, so good!

Nach oben
Rang:
boris



Beiträge: 10136

Titel: (Kein Titel)
Verfasst am: Di, 16 Mai 2006, 11:18
Beitrag
Antworten mit Zitat

LSBMaster @ Mo, 15 Mai 2006, 23:52 gab folgendes von sich:
OK, I figured that out. For anyone who cares, the syntax should be:

Correct. That ist the default-setting when you install UploadPic, so if the install-script does not give you any errors, you should have already had that setting after the installation.


____________
beehave - home of humbug ... [we can't afford to be neutral]

Nach oben
Private Nachricht senden Website dieses Benutzers besuchen Rang:godmode methusalem 3. platz professioneller Sportangler Profi-Winzer (7x Hamm) Arcade-Meister, Rang 16 rainbow-cup
Alkaline





Titel: Kann den Installer nicht aufrufen
Verfasst am: Mi, 12 Jul 2006, 16:22
Beitrag
Antworten mit Zitat

Moin zusammen

ich habe das selbe Problem: "Please remove the install directory", wenn ich versuche den v. 1.3.2. zu installieren.
Mir wäre geholfen, wenn ich die MySQL Statements bekommen könnte, denn ich habe kein EasyMod installiert, stattdessen aber 9 andere Mods....bin halt ein Freund der alten Schule.

Besteht die Möglichkeit, die SQL Statements zu bekommen?

Gruß

Alkaline

Nach oben
Rang:
boris



Beiträge: 10136

Titel: (Kein Titel)
Verfasst am: Do, 13 Jul 2006, 21:29
Beitrag
Antworten mit Zitat

Ich versteh dein Problem nicht ganz ... das Install-Skript von UploadPic hat überhaupt nichts mit EasyMOD zu tun !

Wenn du unbedingt die SQL-Queries "zu Fuß" ausführen willst: die stehen im Install-Skript (wo sie hingehören), wenn du das startest, werden die die Queries auch nochmal angezeigt, falls du dir die da rauskopieren willst (warum du das machen solltest, entzieht sich allerdings meiner Vorstellungskraft).

Ansonsten Suchfunktion nutzen und diesen Beitrag finden (und das ist auch nur die Anzeige des Install-Skripts, dafür ist das schließlich da !):
https://www.beehave.de/forum/viewtopic.php?p=2370#2370


____________
beehave - home of humbug ... [we can't afford to be neutral]

Nach oben
Private Nachricht senden Website dieses Benutzers besuchen Rang:godmode methusalem 3. platz professioneller Sportangler Profi-Winzer (7x Hamm) Arcade-Meister, Rang 16 rainbow-cup
Alkaline





Titel: (Kein Titel)
Verfasst am: Do, 13 Jul 2006, 22:59
Beitrag
Antworten mit Zitat

Hi Boris

zunächst mal vielen Dank für deine Hilfe. Ich hatte sehr wohl die SQL Statements im InstallScript gesehen, es war mir allerdings nicht möglich, es zu installieren, da permanent die Meldung "Remove /install...." kam.
So mache ich morgen mal die SQL Änderungen von Hand und editiere danach die Files.

Ich betreibe ein internes Forum in unserer Firma und bin eher User als Programmierer, daher ist es durchaus möglich, das ich Fehler beim Installieren gemacht haben könnte.... Rolling Eyes
Aber immerhin habe ich bisher 9 Mods erfolgreich ins Forum verbaut und von dem hier erhoffe ich mir die Möglichkeit, in der Message selbst Bilder an genau der Stelle einzufügen, an welcher der Cursor steht....like in Word.....ich werde sehen, ob mir das gelingt.

Nochmals Danke

Gruß

Alkaline

Nach oben
Rang:
boris



Beiträge: 10136

Titel: (Kein Titel)
Verfasst am: Do, 13 Jul 2006, 23:11
Beitrag
Antworten mit Zitat

Also hier habe ich schonmal schrittweise gelistet, wie bei der Installation vorzugehen ist, da sollte dann auch die Fehlermeldung nicht mehr kommen.

Und nur durch das Ausführen der SQL-Queries wird auch das nötige Verzeichnis weder erzeugt noch auf die richtige Schreibberechtigung gesetzt, das mußt du dann auch noch manuell machen ... wie gesagt: das Install-Skript hat schon seinen Sinn ...


____________
beehave - home of humbug ... [we can't afford to be neutral]

Nach oben
Private Nachricht senden Website dieses Benutzers besuchen Rang:godmode methusalem 3. platz professioneller Sportangler Profi-Winzer (7x Hamm) Arcade-Meister, Rang 16 rainbow-cup
Beiträge der letzten Zeit anzeigen:   
Neues Thema eröffnen   Neue Antwort erstellen    beeForum Foren-übersicht » hal9000 » mod support Seite 1 von 1
Gehe zu:  



ähnliche Beiträge
Thema Autor Forum Antworten Verfasst am
Keine neuen Beiträge First World Work Problems jrose hal9000 0 Do, 11 Aug 2011, 09:46 Letzten Beitrag anzeigen
Keine neuen Beiträge Installation kann nicht ausgeführt werden! dadon mod support 7 Do, 10 Jan 2008, 07:45 Letzten Beitrag anzeigen
Keine neuen Beiträge installation no.7 Puge Henis lichtbildausweis(ung) 12 Mo, 08 Okt 2007, 23:44 Letzten Beitrag anzeigen
Keine neuen Beiträge installation no. 2 Puge Henis lichtbildausweis(ung) 1 Mo, 08 Okt 2007, 21:42 Letzten Beitrag anzeigen
Keine neuen Beiträge installation no. 4 Puge Henis lichtbildausweis(ung) 1 Mo, 08 Okt 2007, 21:39 Letzten Beitrag anzeigen


Schreiben: nein. Antworten: nein. Bearbeiten: nein. Löschen: nein. Umfragen: nein.
phpBB © phpBB Group | impressum