Benutzername    Passwort    Autologin    
  Passwort vergessen       Registrieren  
beeForum Foren-übersicht » hal9000 » mod support
Neues Thema eröffnen   Neue Antwort erstellen Hervorhebung entfernen


"500 Internal Server Error" Meldung bei Ausführung
Vorheriges Thema anzeigen :: Nächstes Thema anzeigen  
Autor Nachricht
helluvaguy





Titel: "500 Internal Server Error" Meldung bei Ausführung
Verfasst am: Fr, 23 Jun 2006, 08:31
Beitrag
Antworten mit Zitat

Hallo Boris,

ich bin etwas überrascht durch diese plötzliche Fehlermeldung.
Ich habe den Mod installiert und gestern auch einmal zu Testzwecken genutzt. Dabei habe ich bei alle Benutzer, bis auf einen, die StatusMail deaktiviert. Die Stausmail hat dabei auch wunderbar funktioniert. Alles lief so, wie es sein sollte.

Dann habe ich bei allen Usern wieder 7 Tage eingestellt und es über den gleichen Cronjob laufen lassen, doch diesmal gab es die 500er Fehlermeldung. Ebenfalls manuell ausgelöst passierte das.
Die Cronjobs laufen über meinen Provider und funktinieren ansonsten einwandfrei. WMNotify läuft ebenfalls klaglos darüber.

Gibt es eine Möglichkeit herauszufinden, was diesen Fehler verursacht, oder hast Du eine Vermutung? Könnten fehlende/falsche Emailadressen in den Profilen das Problem sein?

Danke für Deinen Input.

Nach oben
Rang:
boris



Beiträge: 10136

Titel: (Kein Titel)
Verfasst am: Fr, 23 Jun 2006, 09:06
Beitrag
Antworten mit Zitat

Sowas kam bei einem Benutzer von UploadPic bei dem Install-Skript auch schonmal vor ... KEINE Ahnung, was das ist - vor allem: ein "internal server error" ist ja eigentlich nichts, daß am Skript liegt, sondern am Server !

An fehlenden eMail-Adressen kann es auf keinen Fall liegen, denn es gibt in phpBB keine Nutzer, die keine eMail-Adresse haben, an fehlerhaften eigentlich auch nicht, da dann die SMTP-Funktion von phpBB, die die Mails verschickt, einen Fehler ausgeben sollte, nicht aber der Server ...
Du kannst ja mal versuchen, alle Zeilen, die mit dem eMail-Versand zu tun haben, auszukommentieren (alle Zeilen und Code-Blöcke, in denen "$emailer" vorkommt) und es dann nochmal probieren, damit können die Mailprobleme ausgeschlossen werden, aber wie gesagt: bei einem "internal server error" würde ich den Fehler auf der Serverseite vermuten.

Das einzige Mal, wo ich diesen Fehler hatte, war eine .htaccess-Datei mit einem modrewrite in einem Verzeichnis, aber der Server konnte kein modrewrite ... (also ganz klar: Server-Fehler, wie die Meldung schon vermuten läßt)


____________
beehave - home of humbug ... [we can't afford to be neutral]

Nach oben
Private Nachricht senden Website dieses Benutzers besuchen Rang:godmode methusalem 3. platz professioneller Sportangler Profi-Winzer (7x Hamm) Arcade-Meister, Rang 16 rainbow-cup
helluvaguy





Titel: (Kein Titel)
Verfasst am: Fr, 23 Jun 2006, 09:18
Beitrag
Antworten mit Zitat

Ich habe auch gerade festgestellt, dass die Mail an einige User scheinbar doch rausgegangen ist. Zumindest wird in deren Profileinstellungen im ACP als letzte Statusmail der heutige Tag angegeben. Das Script scheint alphabetisch bei den Usernamen vorgegangen zu sein.

Die Erstellung einer Statusmail, gerade bei ersten Mal, kann ja wohl recht lange dauern, da ja auch viel drin ist. Eine diese Mails kam auch gerade an mich zurück. und da waren die Beiträge von knapp 2 Jahren drin aufgelistet. Shocked
Könnte es sozusagen ein Timeout Problem sein?

Das mit den "max. in einem Durchgang zu verschickenden Mails" gilt doch nicht für Cronjobs, oder?

Das mit dem Auskommentieren werde ich auch noch versuchen. Gilt das nur für statusmail.php?

Wäre es nicht evtl eine Möglichkeit, das statusmail_last nicht mit dem user_regdate, sondern dem user_lastvisit zu füllen?

Nach oben
Rang:
helluvaguy





Titel: (Kein Titel)
Verfasst am: Fr, 23 Jun 2006, 09:38
Beitrag
Antworten mit Zitat

Also mit jedem neuen Aufruf, scheinen ein paar User abgearbeitet zu werden, obwohl es zu der Fehlermeldung kommt.

Die Mails gehen definitiv ordnungsgemäß raus, das kann ich sehen. Aber warum dann immer ncoh dieser Fehler? Confused

[EDIT]
Ich habe nun in mühevoller Kleinarbeit den Link immer wieder aufgerufen, bis alle user einmal durchwaren. Danach habe ich das noch mal für mich als Admin gemacht (hatte den Statusmail für mich deaktiviert) und siehe da es ging.

Wird also dann doch sowas wie ein Timeoutproblem gewesen sein, oder?

Nach oben
Rang:
boris



Beiträge: 10136

Titel: (Kein Titel)
Verfasst am: Sa, 24 Jun 2006, 00:16
Beitrag
Antworten mit Zitat

helluvaguy @ Fr, 23 Jun 2006, 09:38 gab folgendes von sich:
Wird also dann doch sowas wie ein Timeoutproblem gewesen sein, oder?

Sieht ganz danach aus ... bei mir hats immer einwandfrei gekappt - entweder ich habe nicht soviele User, nicht soviele Beiträge oder die maximal erlaubte Ausführzeit für Skripte auf meinem Server ist großzügiger.

Die Idee, die Versandzeit bei Instalation nicht auf user_regdate, sondern auf user_lastvisit zu setzen, leuchtet extrem ein (weiß auch nicht, warum ich da das regdate genommen habe) - werde ich bei der nächsten Version direkt umsetzen !


Zur Lösung des Timeouts:
die maximal zu versendende Anzahl von Mails wird nur dann beachtet, wenn StatusMail automatisch (also nicht per CronJob) ausgeführt wird, damit der aufrufende User nicht ewig warten muß, daher heißt die Übergabevariable für den CronJob auch "sendall".

Um das komplette Raussenden der Mails auch beim CronJob-Betrieb zu unterbinden und die im ACP eingestellte maximale Anzahl zu beachten, muß einfach folgendes geändert werden:

Code:
#
#-----[ OPEN ]------------------------------------------
#
includes/statusmail.php

#
#-----[ FIND ]------------------------------------------
#
         if (($int_count >= $board_config['statusmail_maxmail']) && (empty($HTTP_GET_VARS['sendall'])))

#
#-----[ REPLACE WITH ]------------------------------------------
#
         if ($int_count >= $board_config['statusmail_maxmail'])

Wenn du dann den CronJob einfach alle halbe Stunde (oder noch häufiger, je nach Useranzahl) aufrufst, sollte der Versand in kleinen Intervallen ohne Fehler durchlaufen.


____________
beehave - home of humbug ... [we can't afford to be neutral]

Nach oben
Private Nachricht senden Website dieses Benutzers besuchen Rang:godmode methusalem 3. platz professioneller Sportangler Profi-Winzer (7x Hamm) Arcade-Meister, Rang 16 rainbow-cup
helluvaguy





Titel: (Kein Titel)
Verfasst am: Mo, 26 Jun 2006, 10:53
Beitrag
Antworten mit Zitat

Soviele User habe ich eigentlich auch nicht, gerade mal über 200, aber immerhin Beiträge der letzten 2 Jahre im Durchschnitt da rein zu bringen, war sicherlich etwas viel Load.

Ich werde einfach mal sehen, wie es am kommenden Wochenende ist, wenn die nächste Mail fällig wird.

Die Lösung den Cronjob alle 30 Minuten laufen zu lassen kann ich nicht umsetzen, da der nur einmal am Tag von meinem ISP veranlaßt wird.

Nach oben
Rang:
boris



Beiträge: 10136

Titel: (Kein Titel)
Verfasst am: Mo, 26 Jun 2006, 11:34
Beitrag
Antworten mit Zitat

helluvaguy @ Mo, 26 Jun 2006, 10:53 gab folgendes von sich:
aber immerhin Beiträge der letzten 2 Jahre im Durchschnitt da rein zu bringen, war sicherlich etwas viel Load.

Das hat sich jetzt erledigt, der speichert ja, wann die letzte Mail verschickt wurde und ist nur beim allerersten Versand so heftig.

helluvaguy gab folgendes von sich:
Die Lösung den Cronjob alle 30 Minuten laufen zu lassen kann ich nicht umsetzen, da der nur einmal am Tag von meinem ISP veranlaßt wird.

Leg dir doch selber einen z.B. bei cronjob.de an, da bist du nicht auf deinen ISP angewiesen !


____________
beehave - home of humbug ... [we can't afford to be neutral]

Nach oben
Private Nachricht senden Website dieses Benutzers besuchen Rang:godmode methusalem 3. platz professioneller Sportangler Profi-Winzer (7x Hamm) Arcade-Meister, Rang 16 rainbow-cup
Beiträge der letzten Zeit anzeigen:   
Neues Thema eröffnen   Neue Antwort erstellen    beeForum Foren-übersicht » hal9000 » mod support Seite 1 von 1
Gehe zu:  



ähnliche Beiträge
Thema Autor Forum Antworten Verfasst am
Keine neuen Beiträge Gute "How to do ..." - Videos auf Youtube rantanplan le finesnäcker 1 Di, 24 Jan 2017, 17:59 Letzten Beitrag anzeigen
Keine neuen Beiträge Hände weg von "Billigjeans" Hansch joxe und so 2 Mo, 26 Jan 2015, 15:59 Letzten Beitrag anzeigen
Keine neuen Beiträge "Der Meisterfälscher" in der 3sat Mediathek Erdbär silikonimplantate 6 Di, 09 Dez 2014, 11:04 Letzten Beitrag anzeigen
Keine neuen Beiträge Every James Hetfield "Yea"... ever. jrose silikonimplantate 0 Do, 14 März 2013, 21:21 Letzten Beitrag anzeigen
Keine neuen Beiträge film "der verdingsbub" dmarc zelluloid 0 Do, 16 Aug 2012, 22:57 Letzten Beitrag anzeigen


Schreiben: nein. Antworten: nein. Bearbeiten: nein. Löschen: nein. Umfragen: nein.
phpBB © phpBB Group | impressum