Benutzername    Passwort    Autologin    
  Passwort vergessen       Registrieren  
beeForum Foren-übersicht » hal9000 » mod support
Neues Thema eröffnen   Neue Antwort erstellen Hervorhebung entfernen


Uploadpic, problem uploading pics
Gehe zu Seite 1, 2  Weiter Vorheriges Thema anzeigen :: Nächstes Thema anzeigen  
Autor Nachricht
Max





Titel: Uploadpic, problem uploading pics
Verfasst am: Mi, 18 Jan 2006, 02:06
Beitrag
Antworten mit Zitat

Hi, i installed this mod. But when i try to upload a pic i get this errormessage:

Line : 127
File : /home/wis13176/public_html/uploadpic.php

Any ideas what causes it?

Nach oben
Rang:
boris



Beiträge: 10136

Titel: Re: Uploadpic, problem uploading pics
Verfasst am: Mi, 18 Jan 2006, 10:33
Beitrag
Antworten mit Zitat

Max @ Mi, 18 Jan 2006, 01:06 gab folgendes von sich:
Any ideas what causes it?

Well ... as that line in the file uploadpic.php usually gives out an error message, it seems you didn't install the language files correctly - you are probably using a language different to english and did not update your other languages.

The error would be a warning that a file with an unsupported filetype has been uploaded.


____________
beehave - home of humbug ... [we can't afford to be neutral]

Nach oben
Private Nachricht senden Website dieses Benutzers besuchen Rang:godmode methusalem 3. platz professioneller Sportangler Profi-Winzer (7x Hamm) Arcade-Meister, Rang 16 rainbow-cup
Max





Titel: (Kein Titel)
Verfasst am: Do, 19 Jan 2006, 01:11
Beitrag
Antworten mit Zitat

Hi,

Yes it might be, thought so myself. But, i can´t figure out what i shall do. After insallation i got this message:
Zitat:
Note: if you need to install other languages (than english), you will have to execute the corresponding file in the "translations"-directory !

But i can´t get it. Can you describe it in another way...

Thanks!

Nach oben
Rang:
boris



Beiträge: 10136

Titel: (Kein Titel)
Verfasst am: Do, 19 Jan 2006, 13:10
Beitrag
Antworten mit Zitat

As the "other" language doesn't seem to be german (which is the only file in the "translations"-directory), you'll need to fix your lang_main.php and lang_admin.php files for all the other languages manually.
(The next version of UploadPic will contain code that'll make EasyMOD do that automatically, but that won't help you now.)

So just go to to the part in the file uploadpic.txt where the file lang_main.php is opened, do that with any language you like ("/lang_xxx/lang_main.php"), find the appropriate code and insert whatever needs to be inserted (the whole block with the "$lang['xxx'] = "xxx"-statements).
Do that to all your other languages with the lang_admin.php-files as well and you're ready to go.

(If you don't know how to insert MODs, there's a link to a help page in the UploadPic-documentation, I can't grant support for that.)


____________
beehave - home of humbug ... [we can't afford to be neutral]

Nach oben
Private Nachricht senden Website dieses Benutzers besuchen Rang:godmode methusalem 3. platz professioneller Sportangler Profi-Winzer (7x Hamm) Arcade-Meister, Rang 16 rainbow-cup
Max





Titel: (Kein Titel)
Verfasst am: Fr, 20 Jan 2006, 07:59
Beitrag
Antworten mit Zitat

Hm, ok. I hoped that wasen´t all, because i done that...
Nach oben
Rang:
boris



Beiträge: 10136

Titel: (Kein Titel)
Verfasst am: Fr, 20 Jan 2006, 09:47
Beitrag
Antworten mit Zitat

Max @ Fr, 20 Jan 2006, 06:59 gab folgendes von sich:
Hm, ok. I hoped that wasen´t all, because i done that...

If you're still getting that error without the error message, there's definitely something wrong with your language files otherwise an error message would be displayed !


____________
beehave - home of humbug ... [we can't afford to be neutral]

Nach oben
Private Nachricht senden Website dieses Benutzers besuchen Rang:godmode methusalem 3. platz professioneller Sportangler Profi-Winzer (7x Hamm) Arcade-Meister, Rang 16 rainbow-cup
Max





Titel: (Kein Titel)
Verfasst am: Di, 24 Jan 2006, 00:38
Beitrag
Antworten mit Zitat

Hi,

i get this error:
Code:
Warning: getimagesize(): open_basedir restriction in effect. File(/var/tmp/phpuXItte) is not within the allowed path(s): (/home/wis13176:/usr/lib/php:/usr/local/lib/php:/tmp) in /home/wis13176/public_html/uploadpic.php on line 121

Warning: getimagesize(/var/tmp/phpuXItte): failed to open stream: Operation not permitted in /home/wis13176/public_html/uploadpic.php on line 121

Warning: Cannot modify header information - headers already sent by (output started at /home/wis13176/public_html/uploadpic.php:121) in /home/wis13176/public_html/includes/page_header.php on line 615

Warning: Cannot modify header information - headers already sent by (output started at /home/wis13176/public_html/uploadpic.php:121) in /home/wis13176/public_html/includes/page_header.php on line 617

Warning: Cannot modify header information - headers already sent by (output started at /home/wis13176/public_html/uploadpic.php:121) in /home/wis13176/public_html/includes/page_header.php on line 618

And then comes "the box" with this:
Code:
DEBUG MODE

Line : 127
File : /home/wis13176/public_html/uploadpic.php

Thanks for helping me out!

Nach oben
Rang:
boris



Beiträge: 10136

Titel: (Kein Titel)
Verfasst am: Di, 24 Jan 2006, 01:14
Beitrag
Antworten mit Zitat

Max @ Mo, 23 Jan 2006, 23:38 gab folgendes von sich:
Line : 127
File : /home/wis13176/public_html/uploadpic.php

Again, I can't tell you more than this: the error message that you're getting must have a message in it, not just the line and the file - and the only way of getting to this point is NOT installing the language files correctly.

Plus: there's something wrong with your paths, so try the new version (1.2.6, here) and follow ALL the instructions in the readme-file and the MOD-file (uploadpic.txt) itself.
If it still doesn't work, post your "script_path"-variable (table "phpbb_config" in your database) and your setting of "uploadpic_picpath" here exactly as entered in the database.
(If you don't know how to get those values, check the UploadPic-docs, there's a link on how to use phpMyAdmin.)


____________
beehave - home of humbug ... [we can't afford to be neutral]

Nach oben
Private Nachricht senden Website dieses Benutzers besuchen Rang:godmode methusalem 3. platz professioneller Sportangler Profi-Winzer (7x Hamm) Arcade-Meister, Rang 16 rainbow-cup
Max





Titel: (Kein Titel)
Verfasst am: Di, 24 Jan 2006, 22:26
Beitrag
Antworten mit Zitat

Ok, updated and this is what i get:


I also created a folder in root called userpix, and set it to chmod 777. Im not sure if this is all you asked about, but here are my settings in phpbb_config:
Code:
--
-- Struktur för tabell `phpbb_config`
--

CREATE TABLE `phpbb_config` (
  `config_name` varchar(255) NOT NULL default '',
  `config_value` varchar(255) NOT NULL default '',
  PRIMARY KEY  (`config_name`)
) TYPE=MyISAM;

--
-- Data i tabell `phpbb_config`
--

INSERT INTO `phpbb_config` VALUES ('uploadpic_picdir', '/userpix/');
INSERT INTO `phpbb_config` VALUES ('uploadpic_uniqfn', '1');
INSERT INTO `phpbb_config` VALUES ('uploadpic_delete', '1');
INSERT INTO `phpbb_config` VALUES ('uploadpic_lrmod', '');
INSERT INTO `phpbb_config` VALUES ('uploadpic_showlink', '0');
INSERT INTO `phpbb_config` VALUES ('uploadpic_vbbcode', '1');
INSERT INTO `phpbb_config` VALUES ('uploadpic_maxsize', '100000');
INSERT INTO `phpbb_config` VALUES ('uploadpic_maxpicx', '550');
INSERT INTO `phpbb_config` VALUES ('uploadpic_maxpicy', '450');
INSERT INTO `phpbb_config` VALUES ('uploadpic_minimum', '15');
INSERT INTO `phpbb_config` VALUES ('uploadpic_allowed', 'image/jpg|image/jpeg|image/pjpeg|image/gif|image/png|image/x-png|image/x-   citrix-pjpeg');
INSERT INTO `phpbb_config` VALUES ('uploadpic_allowpm', '1');
INSERT INTO `phpbb_config` VALUES ('uploadpic_maxpmdays', '30');
INSERT INTO `phpbb_config` VALUES ('uploadpic_jpgqual', '100');
INSERT INTO `phpbb_config` VALUES ('uploadpic_gallery', '1');
INSERT INTO `phpbb_config` VALUES ('uploadpic_gallerysize', '250');
INSERT INTO `phpbb_config` VALUES ('uploadpic_watermark', '');
INSERT INTO `phpbb_config` VALUES ('uploadpic_wmpicture', 'images/up_watermark.png');
INSERT INTO `phpbb_config` VALUES ('uploadpic_wmposition', '6');
INSERT INTO `phpbb_config` VALUES ('uploadpic_wmpicx', '150');
INSERT INTO `phpbb_config` VALUES ('uploadpic_wmpicy', '150');
INSERT INTO `phpbb_config` VALUES ('uploadpic_information', '');
INSERT INTO `phpbb_config` VALUES ('uploadpic_multiple', '');
[/img]

Nach oben
Rang:
boris



Beiträge: 10136

Titel: (Kein Titel)
Verfasst am: Di, 24 Jan 2006, 22:47
Beitrag
Antworten mit Zitat

Max @ Di, 24 Jan 2006, 21:26 gab folgendes von sich:
Im not sure if this is all you asked about, but here are my settings in phpbb_config:

There's another important variable in that table: "script_path" ... should be set to something like "/" in your case (don't change it, version 1.2.6 of UploadPic should be able to deal with any value), the value for uploadpic_picpath is ok (if you forum's in the root of your domain).

Looks like you're either using domain-forwarding (your files are not what your domain name suggests but in another directory) and/or your server settings don't allow uploads and the dealing with uploaded files (which is necessary to use UploadPic).
Both ways: you should contact your server administrator to check for the basedir-restrictions as the path-variables seem to be set to the correct values.


____________
beehave - home of humbug ... [we can't afford to be neutral]

Nach oben
Private Nachricht senden Website dieses Benutzers besuchen Rang:godmode methusalem 3. platz professioneller Sportangler Profi-Winzer (7x Hamm) Arcade-Meister, Rang 16 rainbow-cup
Max





Titel: (Kein Titel)
Verfasst am: Di, 24 Jan 2006, 23:01
Beitrag
Antworten mit Zitat

Ok, i will do that. I use smartors Photo Album Addon aswell and that works just fine...

Get back to you when i spoked with my host.

Thankyou!

EDIT: And yes, my scriptpath is: /

Nach oben
Rang:
Max





Titel: (Kein Titel)
Verfasst am: Mi, 25 Jan 2006, 11:34
Beitrag
Antworten mit Zitat

Hi again,

Yes it was the server settings that caused the problem. Now it´s working like a charm. Thanks a lot for your support and nice mod! Very Happy

EDIT-->
My host says that he opened "open_basedir restriction in effect" and that it´s a big securityrisk, and that they will not be responible if my site got hacked because of that. Is this correct, and is it that they had to do to get it working?

Nach oben
Rang:
boris



Beiträge: 10136

Titel: (Kein Titel)
Verfasst am: Mi, 25 Jan 2006, 12:50
Beitrag
Antworten mit Zitat

Max @ Mi, 25 Jan 2006, 10:34 gab folgendes von sich:
My host says that he opened "open_basedir restriction in effect" and that it´s a big securityrisk, and that they will not be responible if my site got hacked because of that.

If he opened the restriction to any script (I don't even know, if that's possible), then: yese, because you don't want anybody executing scripts from anywhere accessing your files.
But as I said: I don't even think that's possible, the removed basedir-restriction should only affect scripts in the same path (web/domain), if your host made your files accessible to anyone from anywhere, he should change that.

Max gab folgendes von sich:
Is this correct, and is it that they had to do to get it working?

The server-restriction made the UploadPic-script throw that error because it could not access the uploaded file ... that's pretty much all I can say about it as I don't really know much about servers and their settings ...

If I find the time, I'll check out how the album-MOD handles the uploads. Maybe there's another way of doing it which won't collide with server settings, even though I can't think of one as there's no way of processing uploaded pictures without accessing them ... big grin


____________
beehave - home of humbug ... [we can't afford to be neutral]

Nach oben
Private Nachricht senden Website dieses Benutzers besuchen Rang:godmode methusalem 3. platz professioneller Sportangler Profi-Winzer (7x Hamm) Arcade-Meister, Rang 16 rainbow-cup
boris



Beiträge: 10136

Titel: (Kein Titel)
Verfasst am: Do, 26 Jan 2006, 22:07
Beitrag
Antworten mit Zitat

I checked this again and it should be possible for the admin to add just a single path (which is the path to your upload-directory, in your case var/tmp) to the open_basedir in the file php.ini.
If you do just that, there should be now security-issues at all.

EDIT:
Did some more checking and the album MOD actually treats the uploaded files differently: they are first moved to the destination directory and the change (didn't know that would make a difference) ... I'll check that function for UploadPic and include it in the next update.


____________
beehave - home of humbug ... [we can't afford to be neutral]

Nach oben
Private Nachricht senden Website dieses Benutzers besuchen Rang:godmode methusalem 3. platz professioneller Sportangler Profi-Winzer (7x Hamm) Arcade-Meister, Rang 16 rainbow-cup
Max





Titel: (Kein Titel)
Verfasst am: Fr, 27 Jan 2006, 00:27
Beitrag
Antworten mit Zitat

boris @ Do, 26 Jan 2006, 21:07 gab folgendes von sich:
I checked this again and it should be possible for the admin to add just a single path (which is the path to your upload-directory, in your case var/tmp) to the open_basedir in the file php.ini.
If you do just that, there should be now security-issues at all.

Ok, thankyou. I mailed my host and told him this.

boris @ Do, 26 Jan 2006, 21:07 gab folgendes von sich:
EDIT:
Did some more checking and the album MOD actually treats the uploaded files differently: they are first moved to the destination directory and the change (didn't know that would make a difference) ... I'll check that function for UploadPic and include it in the next update.

Sounds really good. I like your mod a lot, been looking for something like this a while since all i been looking for was to upload only pics.

Nach oben
Rang:
boris



Beiträge: 10136

Titel: (Kein Titel)
Verfasst am: Fr, 27 Jan 2006, 00:51
Beitrag
Antworten mit Zitat

Max @ Do, 26 Jan 2006, 23:27 gab folgendes von sich:
Ok, thankyou. I mailed my host and told him this.

I changed UploadPic and I'm now checking the new version. As long as you have at least PHP v4.0.3 you should be able to set your server settings back to normal as the open_basedir-restriction should not occur once I get the version all finished.

Didn't think the treating of the files made a difference ... you never stop learning Wink


____________
beehave - home of humbug ... [we can't afford to be neutral]

Nach oben
Private Nachricht senden Website dieses Benutzers besuchen Rang:godmode methusalem 3. platz professioneller Sportangler Profi-Winzer (7x Hamm) Arcade-Meister, Rang 16 rainbow-cup
Max





Titel: (Kein Titel)
Verfasst am: Sa, 28 Jan 2006, 23:51
Beitrag
Antworten mit Zitat

boris @ Do, 26 Jan 2006, 21:07 gab folgendes von sich:
I checked this again and it should be possible for the admin to add just a single path (which is the path to your upload-directory, in your case var/tmp) to the open_basedir in the file php.ini.
If you do just that, there should be now security-issues at all.

My hostadmin did this and it works, thanks for the info. Another thing, that has nothing to with this is if it´s possible to intergrate UploadPic with the easyCMS (found here: http://www.phpbbhacks.com/download/1411 ). There is a mod that integrates the File Attachment Hack to easyCMS: http://www.phpbbhacks.com/download/2128
Is it possible to make something similar?

Nach oben
Rang:
boris



Beiträge: 10136

Titel: (Kein Titel)
Verfasst am: So, 29 Jan 2006, 20:40
Beitrag
Antworten mit Zitat

Max @ Sa, 28 Jan 2006, 22:51 gab folgendes von sich:
Another thing, that has nothing to with this is if it´s possible to intergrate UploadPic with the easyCMS

I'll have to check, what the easyCMS does and how it works, as I'm not using it myself.
I'm currently working on making UploadPic work with the "Knowledge Base", once I get that done, I'll check out easyCMS.


____________
beehave - home of humbug ... [we can't afford to be neutral]

Nach oben
Private Nachricht senden Website dieses Benutzers besuchen Rang:godmode methusalem 3. platz professioneller Sportangler Profi-Winzer (7x Hamm) Arcade-Meister, Rang 16 rainbow-cup
Max





Titel: (Kein Titel)
Verfasst am: So, 29 Jan 2006, 23:14
Beitrag
Antworten mit Zitat

Thankyou, it would be really great if it´s possible to use UploadPic in easyCMS!
Nach oben
Rang:
Max





Titel: (Kein Titel)
Verfasst am: Mi, 15 Feb 2006, 01:55
Beitrag
Antworten mit Zitat

Hi Boris,

Really great that you integrated UploadPic with the easyCMS! But i have one problem after modding cms_post_comment.php. I get this when i try to post a comment to an article:
Code:
Parse error: parse error, unexpected $ in /home/wis13176/public_html/cms_post_comment.php on line 707

There is no problem with cms_post_article.php when you want to post a new article. Tryed to solve it, but can´t get it right...

Nach oben
Rang:
Beiträge der letzten Zeit anzeigen:   
Neues Thema eröffnen   Neue Antwort erstellen    beeForum Foren-übersicht » hal9000 » mod support Seite 1 von 2
Gehe zu Seite 1, 2  Weiter
Gehe zu:  



ähnliche Beiträge
Thema Autor Forum Antworten Verfasst am
Keine neuen Beiträge uploadpic auf orion phpBB instalieren hewika mod support 9 Mo, 03 Jan 2011, 21:18 Letzten Beitrag anzeigen
Keine neuen Beiträge uploadpic Problem -> hilfe benötigt Dakota mod support 1 So, 15 Aug 2010, 15:39 Letzten Beitrag anzeigen
Keine neuen Beiträge Major Problem UncleR internet junk 0 Do, 19 Feb 2009, 14:51 Letzten Beitrag anzeigen
Keine neuen Beiträge Chris Baty - No Plot? No Problem! boris kühnes mittelscharfer 0 So, 23 Nov 2008, 17:30 Letzten Beitrag anzeigen
Keine neuen Beiträge UploadPic 1.3.7 Imagerotate Morpheus mod support 2 Mo, 08 Sep 2008, 19:41 Letzten Beitrag anzeigen


Schreiben: nein. Antworten: nein. Bearbeiten: nein. Löschen: nein. Umfragen: nein.
phpBB © phpBB Group | impressum