Benutzername    Passwort    Autologin    
  Passwort vergessen       Registrieren  
beeForum Foren-übersicht » hal9000 » mod support
Neues Thema eröffnen   Neue Antwort erstellen Hervorhebung entfernen


UploadPic problem: pictures not found
Vorheriges Thema anzeigen :: Nächstes Thema anzeigen  
Autor Nachricht
noonoo





Titel: UploadPic problem: pictures not found
Verfasst am: Mo, 28 Nov 2005, 02:18
Beitrag
Antworten mit Zitat

Hi guys, sorry to post on a german forum in english but i hope you can help.

o.k. i installed upload pic and it seems to work fine in the admin panel and when i click the link in posting the box comes up ok. but i have a small problem

when i choose a file to upload and click send i get upload box with no picture inside and then if i click insert link or picture it posts to a file but still no picture, if i goto admin panel the picture is listed but no image is there. just the warning. its as if everything is working ok but the picture isant being stored or uploaded properly.

also is there a way for users to see what pictures they have already uploaded, like a personal gallery or something so that they only have to upload an image once.

any help would be great
many thanks in advance

noonoo Smile Smile Smile


Zuletzt bearbeitet von noonoo am Mo, 28 Nov 2005, 19:39, insgesamt einmal bearbeitet. (1 Prozent)

Nach oben
Rang:
boris



Beiträge: 10136

Titel: Re: upload pic problem
Verfasst am: Mo, 28 Nov 2005, 12:15
Beitrag
Antworten mit Zitat

noonoo gab folgendes von sich:
when i choose a file to upload and click send i get upload box with no picture inside

What is your userpix-dir ? It should probably be "/userpix/" in your case.
Do you get any error message ?
Do you use UploadPic's version 1.1.3 and the install-script ? There were path-problems on Windows-servers with version 1.0.0.

noonoo gab folgendes von sich:
also is there a way for users to see what pictures they have already uploaded, like a personal gallery

Not yet, but I put it on the "requested feature" list. If I (ever Smile) find the time for an update, I may include it.


____________
beehave - home of humbug ... [we can't afford to be neutral]

Nach oben
Private Nachricht senden Website dieses Benutzers besuchen Rang:godmode methusalem 3. platz professioneller Sportangler Profi-Winzer (7x Hamm) Arcade-Meister, Rang 16 rainbow-cup
noonoo





Titel: (Kein Titel)
Verfasst am: Mo, 28 Nov 2005, 13:09
Beitrag
Antworten mit Zitat

hi,

my userpix-dir is root/userpix/
when i try to upload a picture everything seems fine and the picture gets stored into userpix, the problem is instead of showing the picture i get the picture error sign instead. no error messaged.

no i have installed upload pic v1.1.2

i have just downloaded v1.1.3 i will try this and report back

Nach oben
Rang:
boris



Beiträge: 10136

Titel: (Kein Titel)
Verfasst am: Mo, 28 Nov 2005, 13:19
Beitrag
Antworten mit Zitat

noonoo gab folgendes von sich:
my userpix-dir is root/userpix/

it should be "/userpix/" if your forum is in your domain-root, no "root" or anything else enterd in the path, the two slashes are mandatory

still something is obviously going wrong with the upload - the http-path of your picture seems correct but the image-file isn't there ...
when I try to access your picture, I get the following response: "You don't have permission to access /userpix/2_1211_1.jpg on this server."
looks like the picture is there but I'm not allowed to access it - are you sure the directory-permissions are set to "777" (read/write/executable by anybody) ??

noonoo gab folgendes von sich:
were can i fing the latest version.

right here, just click on "download"
the path-problems occured in v1.0.0 only, 1.1.2 should be fine, still it's a good idea to update


____________
beehave - home of humbug ... [we can't afford to be neutral]

Nach oben
Private Nachricht senden Website dieses Benutzers besuchen Rang:godmode methusalem 3. platz professioneller Sportangler Profi-Winzer (7x Hamm) Arcade-Meister, Rang 16 rainbow-cup
noonoo





Titel: (Kein Titel)
Verfasst am: Mo, 28 Nov 2005, 13:30
Beitrag
Antworten mit Zitat

hi, i have not set the directory permissions i left it to the install_uploadpic.php to make the directory which it did. i tried changing to v1.1.3 but as you thought did not fix.

its so wierd when i upload a picture in the preview screen were it has the address for the pic, the error picture is the same size as what the picture should be.

and userpix is in my root, so its turbocarclub.co.uk/userpix/

ok i just downloaded the userpix file from my server, and sure enough my pictures were inside and ok. so something is stopping my pictures being seen when just uploaded and when posted. any ideas ???

Nach oben
Rang:
boris



Beiträge: 10136

Titel: (Kein Titel)
Verfasst am: Mo, 28 Nov 2005, 14:01
Beitrag
Antworten mit Zitat

noonoo gab folgendes von sich:
the error picture is the same size as what the picture should be.

that's perfectly normal: the script calculates the image-dimensions (changes them, if necessary) and gives the resulting height and width to the image-tag in the preview.

noonoo gab folgendes von sich:
so something is stopping my pictures being seen when just uploaded and when posted. any ideas ???

If your forum is running on a Windows-Server the install-script may not be able to set the permissions for the directory, you may have to check the permissions of the directory manually.

if this: turbocarclub.co.uk/userpix/2_1211_1.jpg is the correct URL of you uploaded picture AND the file is there (check with FTP), the permissions are not set correctly as I cannot access it with my browser (403 forbidden) !

If you're running a linux-server, I'm running out of ideas here ... stunned


____________
beehave - home of humbug ... [we can't afford to be neutral]

Nach oben
Private Nachricht senden Website dieses Benutzers besuchen Rang:godmode methusalem 3. platz professioneller Sportangler Profi-Winzer (7x Hamm) Arcade-Meister, Rang 16 rainbow-cup
noonoo





Titel: SOLVED / FIXED
Verfasst am: Mo, 28 Nov 2005, 14:20
Beitrag
Antworten mit Zitat

good news,

while the install file created the /userpix/ directory it did not give it the correct permissions. changed that and now all works as it should.

you were quite right

many thanks for replying so quickly and helping me out i really appretiate that, i wish all people that made mods gave the same support.

once again many thanks Very Happy Very Happy Very Happy Very Happy Very Happy

look forward to the next release

noonoo (nick)

Nach oben
Rang:
boris



Beiträge: 10136

Titel: Re: SOLVED / FIXED
Verfasst am: Mo, 28 Nov 2005, 15:06
Beitrag
Antworten mit Zitat

noonoo gab folgendes von sich:
while the install file created the /userpix/ directory it did not give it the correct permissions. changed that and now all works as it should.

as far as I know this only happens on Windows-servers as they don't understand the "chmod"-statement.
I'll put a hint in the install-script and the FAQ.

noonoo gab folgendes von sich:
i wish all people that made mods gave the same support.

i wish I could program a MOD that'll run on any system without errors right away Wink

noonoo gab folgendes von sich:
look forward to the next release

I could probably publish that a lot ealier if I wasn't giving all that support Cool


____________
beehave - home of humbug ... [we can't afford to be neutral]

Nach oben
Private Nachricht senden Website dieses Benutzers besuchen Rang:godmode methusalem 3. platz professioneller Sportangler Profi-Winzer (7x Hamm) Arcade-Meister, Rang 16 rainbow-cup
Beiträge der letzten Zeit anzeigen:   
Neues Thema eröffnen   Neue Antwort erstellen    beeForum Foren-übersicht » hal9000 » mod support Seite 1 von 1
Gehe zu:  



ähnliche Beiträge
Thema Autor Forum Antworten Verfasst am
Keine neuen Beiträge uploadpic auf orion phpBB instalieren hewika mod support 9 Mo, 03 Jan 2011, 21:18 Letzten Beitrag anzeigen
Keine neuen Beiträge uploadpic Problem -> hilfe benötigt Dakota mod support 1 So, 15 Aug 2010, 15:39 Letzten Beitrag anzeigen
Keine neuen Beiträge Major Problem UncleR internet junk 0 Do, 19 Feb 2009, 14:51 Letzten Beitrag anzeigen
Keine neuen Beiträge Chris Baty - No Plot? No Problem! boris kühnes mittelscharfer 0 So, 23 Nov 2008, 17:30 Letzten Beitrag anzeigen
Keine neuen Beiträge UploadPic 1.3.7 Imagerotate Morpheus mod support 2 Mo, 08 Sep 2008, 19:41 Letzten Beitrag anzeigen


Schreiben: nein. Antworten: nein. Bearbeiten: nein. Löschen: nein. Umfragen: nein.
phpBB © phpBB Group | impressum