Benutzername    Passwort    Autologin    
  Passwort vergessen       Registrieren  
beeForum Foren-übersicht » hal9000 » mod support
Neues Thema eröffnen   Neue Antwort erstellen Hervorhebung entfernen


Problem with admin_users.php
Vorheriges Thema anzeigen :: Nächstes Thema anzeigen  
Autor Nachricht
yavor50





Titel: Problem with admin_users.php
Verfasst am: Fr, 21 Jul 2006, 14:34
Beitrag
Antworten mit Zitat

He there,

I'm using phpBB v. 2.0.21
I've installed uploadpic following the instructions, but when I try to enter the admin mode I get the following message:

Parse error: syntax error, unexpected '=' in /home/bezdom/public_html/forum/admin/admin_users.php on line 237

I get the messege if I make all the changes in admin_users.php or even if I make only one of the changes /doesn't matter which one/.
I've reinstalled only the admin_users.php from the backup file and everythiing works fine, except the permissions for users to upload pictures - the "save" button simply doesn't work.

Any ideas how to fix this? Thanks in advance.

P.S. The only other MOD I have on the forum is Admin Userlist 202.

Nach oben
Rang:
boris



Beiträge: 10136

Titel: (Kein Titel)
Verfasst am: Fr, 21 Jul 2006, 19:23
Beitrag
Antworten mit Zitat

A "parse error" is always a sign that you made a mistake while changing the file. I just tried to install UploadPic with a fresh 2.0.21 installation of phpBB and everything worked out fine, so the problem is not within UploadPic or its installation-docs !

Try to repeat the steps, use EasyMOD if you can't do it on your own. Also read the MOD-installation FAQ on phpbb.com for more help.
Check if the other MOD (I don't know it) also changed the file admin_users.php and if this affects the parts that have to be changed for UploadPic, make sure you change the code exactly as stated in the docs.


____________
beehave - home of humbug ... [we can't afford to be neutral]

Nach oben
Private Nachricht senden Website dieses Benutzers besuchen Rang:godmode methusalem 3. platz professioneller Sportangler Profi-Winzer (7x Hamm) Arcade-Meister, Rang 16 rainbow-cup
yavor50





Titel: (Kein Titel)
Verfasst am: Fr, 21 Jul 2006, 22:16
Beitrag
Antworten mit Zitat

Thanks a lot. As everything else with the MOD is working fine, is there anything simple I can do to check the permission for all users on YES?
And one final question - when do I have to run the install_uploadpic.php? Before editing all files /as the uploadpic.txt suggests/ or after that /as the readme.txt says/?
Thanks again for the help.

Nach oben
Rang:
boris



Beiträge: 10136

Titel: (Kein Titel)
Verfasst am: Sa, 22 Jul 2006, 15:36
Beitrag
Antworten mit Zitat

yavor50 gab folgendes von sich:
is there anything simple I can do to check the permission for all users on YES?

Have you tried "UploadPic users" in the ACP ???

yavor50 gab folgendes von sich:
when do I have to run the install_uploadpic.php?

That doesn't matter, but definitely before using UploadPic.


____________
beehave - home of humbug ... [we can't afford to be neutral]

Nach oben
Private Nachricht senden Website dieses Benutzers besuchen Rang:godmode methusalem 3. platz professioneller Sportangler Profi-Winzer (7x Hamm) Arcade-Meister, Rang 16 rainbow-cup
yavor50





Titel: (Kein Titel)
Verfasst am: Sa, 22 Jul 2006, 17:53
Beitrag
Antworten mit Zitat

boris @ Sa, 22 Jul 2006, 15:36 gab folgendes von sich:
yavor50 gab folgendes von sich:
is there anything simple I can do to check the permission for all users on YES?

Have you tried "UploadPic users" in the ACP ???


Yes - the "save" button does not work when I use the unaltered admin_users.php. When I use the changed admin_users.php the ACP does not work at all - just the parse error message appears...

Nach oben
Rang:
boris



Beiträge: 10136

Titel: (Kein Titel)
Verfasst am: Sa, 22 Jul 2006, 18:21
Beitrag
Antworten mit Zitat

yavor50 @ Sa, 22 Jul 2006, 17:53 gab folgendes von sich:
the "save" button does not work when I use the unaltered admin_users.php.

The file admin_uploadpic_users.php (= "UploadPic users" in the ACP) has nothing to do with the changes you make in admin_users.php ! It's a seperate file you have to upload and it's working fine.

yavor50 gab folgendes von sich:
When I use the changed admin_users.php the ACP does not work at all - just the parse error message appears...

As I said: use EasyMOD to install UploadPic, there is no error in the UploadPic-code or the install-instructions !


____________
beehave - home of humbug ... [we can't afford to be neutral]

Nach oben
Private Nachricht senden Website dieses Benutzers besuchen Rang:godmode methusalem 3. platz professioneller Sportangler Profi-Winzer (7x Hamm) Arcade-Meister, Rang 16 rainbow-cup
yavor50





Titel: (Kein Titel)
Verfasst am: Sa, 22 Jul 2006, 21:19
Beitrag
Antworten mit Zitat

OK, I've installed the MOD again, this time with easyMOD. THe "save" button in the Upload Pic users still doesn't work...
Can I change the permissions manually?

Nach oben
Rang:
boris



Beiträge: 10136

Titel: (Kein Titel)
Verfasst am: So, 23 Jul 2006, 22:55
Beitrag
Antworten mit Zitat

yavor50 @ Sa, 22 Jul 2006, 21:19 gab folgendes von sich:
THe "save" button in the Upload Pic users still doesn't work...

What exactly doesn't work ?? UploadPic has been downloaded and installed by several thousand people and nobody ever complained about that part "not working" ... so I truly believe that something about your configuration, server-settings, PHP- and/or phpBB-versions is not as it should be and that there's absolutely nothing wrong with UploadPic itself ...

yavor50 gab folgendes von sich:
Can I change the permissions manually?

Sure, just got to your phpMyAdmin and change the field "user_allow_uploadpic" in the table "phpbb_users".
Value "1" means "is allowed to upload", value "0" means "not allowed".
Check the FAQ, chapter II. 10. to see how to change the default.


____________
beehave - home of humbug ... [we can't afford to be neutral]

Nach oben
Private Nachricht senden Website dieses Benutzers besuchen Rang:godmode methusalem 3. platz professioneller Sportangler Profi-Winzer (7x Hamm) Arcade-Meister, Rang 16 rainbow-cup
phpBB





Titel: SAVE BUTTON
Verfasst am: Di, 31 Okt 2006, 21:13
Beitrag
Antworten mit Zitat

I have the same problem with Save button, I always have the same result "The page you are looking for is currently unavailable..."

When I'm logged in the forum the MOD works fine but if I logg in the ACP then the uploadpic in the forum stop working, te messege in the pop up window is the same "The page you are looking for is currently unavailable..."

Please help me!

Nach oben
Rang:
boris



Beiträge: 10136

Titel: (Kein Titel)
Verfasst am: Mi, 01 Nov 2006, 15:14
Beitrag
Antworten mit Zitat

1. the phpBB-account is only for testing purposes !
2. "page not found"-errors are always a matter of errors in your config either the phpBB-config or the server-config (or both), not a problem of UploadPic, read the FAQ


____________
beehave - home of humbug ... [we can't afford to be neutral]

Nach oben
Private Nachricht senden Website dieses Benutzers besuchen Rang:godmode methusalem 3. platz professioneller Sportangler Profi-Winzer (7x Hamm) Arcade-Meister, Rang 16 rainbow-cup
Beiträge der letzten Zeit anzeigen:   
Neues Thema eröffnen   Neue Antwort erstellen    beeForum Foren-übersicht » hal9000 » mod support Seite 1 von 1
Gehe zu:  



ähnliche Beiträge
Thema Autor Forum Antworten Verfasst am
Keine neuen Beiträge uploadpic Problem -> hilfe benötigt Dakota mod support 1 So, 15 Aug 2010, 15:39 Letzten Beitrag anzeigen
Keine neuen Beiträge Major Problem UncleR internet junk 0 Do, 19 Feb 2009, 14:51 Letzten Beitrag anzeigen
Keine neuen Beiträge Chris Baty - No Plot? No Problem! boris kühnes mittelscharfer 0 So, 23 Nov 2008, 17:30 Letzten Beitrag anzeigen
Keine neuen Beiträge Upload Pic Problem mit User Rechte meme mod support 2 Mo, 21 Jan 2008, 15:29 Letzten Beitrag anzeigen
Keine neuen Beiträge Uploadpic Problem: Unknown list entry type in reques... fupp mod support 2 Sa, 19 Jan 2008, 14:05 Letzten Beitrag anzeigen


Schreiben: nein. Antworten: nein. Bearbeiten: nein. Löschen: nein. Umfragen: nein.
phpBB © phpBB Group | impressum