Benutzername    Passwort    Autologin    
  Passwort vergessen       Registrieren  
beeForum Foren-übersicht » hal9000 » mod support
Neues Thema eröffnen   Neue Antwort erstellen Hervorhebung entfernen


Fehlermeldung bei /install/install_uploadpic.php
Vorheriges Thema anzeigen :: Nächstes Thema anzeigen  
Autor Nachricht
Värmländer





Titel: Fehlermeldung bei /install/install_uploadpic.php
Verfasst am: Mo, 13 Feb 2006, 13:16
Beitrag
Antworten mit Zitat

Hej hej!

Nachdem es so viele neue Funktionen für UploadPic gibt, habe
ich mich mal drangesetzt, und schrittweise von 1.1.2 nach 1.3.0
geupdatet.

Wenn ich die install/install_uploadpic.php ausführen möchte,
erhalte ich folgende Fehlermeldung Sad

Warning: implode(): Bad arguments. in /var/kunden/webs/XXXXX/phpBB2/install/install_uploadpic.php on line 159

Woran kann das liegen?

Liebe Grüße
Andreas

Nach oben
Rang:
boris



Beiträge: 10136

Titel: Re: Fehlermeldung bei /install/install_uploadpic.php
Verfasst am: Mo, 13 Feb 2006, 15:37
Beitrag
Antworten mit Zitat

Värmländer @ Mo, 13 Feb 2006, 12:16 gab folgendes von sich:
Woran kann das liegen?

Das ist eine sehr gute Frage, vor allem, da das Install-Skript nicht (mehr) von mir ist sondern ich jetzt die Standard-Routine von phpbb.com nutze Sad

Für doch mal in die Install-Datei diese Zeile:
print_r($sql);
vor die Zeile 159 ein, mal sehen, was dann kommt. (Es sollte das Array mit den Datenbankänderungen ausgegeben werden.)


EDIT:
Welche PHP-Version benutzt du ?
Hab mal ein bisschen gegoogelt: es scheint, daß es in der neuen Version (5.x) Änderungen bezüglich der Behandlung von Arrays gibt, die phpbb.com noch nicht berücksichtigt.
Allerdings habe ich in meiner Testumgebung (soweit ich weiß) PHP5 drauf und da lief das Skript ... confused4


____________
beehave - home of humbug ... [we can't afford to be neutral]

Nach oben
Private Nachricht senden Website dieses Benutzers besuchen Rang:godmode methusalem 3. platz professioneller Sportangler Profi-Winzer (7x Hamm) Arcade-Meister, Rang 16 rainbow-cup
Värmländer





Titel: (Kein Titel)
Verfasst am: Mo, 13 Feb 2006, 16:11
Beitrag
Antworten mit Zitat

Hej Boris!

Erst mal Dankeschön für die schnelle Rückmeldung!

Hmmm, welche PHP-Version ??
Bei mir steht folgendes:
Zitat:
Willkommen bei phpMyAdmin 2.6.4-pl2
Verbunden mit MySQL 4.0.24_Debian-10sarge1-log auf localhost als XXXXXsql1@localhost



Boris gab folgendes von sich:
Für doch mal in die Install-Datei diese Zeile:
print_r($sql);
vor die Zeile 159 ein, mal sehen, was dann kommt


Ähhh Embarassed , wie finde ich denn die Zeile 159?
Ich arbeite mit dem normalen Editor von Windows, und der zeigt mir keine
Zeilennummerierung an.
Hast du einen Tipp für mich?

Liebe Grüße nach Köln
Andreas

Nach oben
Rang:
boris



Beiträge: 10136

Titel: (Kein Titel)
Verfasst am: Mo, 13 Feb 2006, 16:17
Beitrag
Antworten mit Zitat

Värmländer @ Mo, 13 Feb 2006, 15:11 gab folgendes von sich:
Hmmm, welche PHP-Version ?? Bei mir steht folgendes:

Das ist die SQL-Version, leg mal eine PHP-Datei auf deinem Webspace an mit folgendem Inhalt:
Code:
<?
phpinfo();
?>

und ruf die auf bzw. poste den Link zur Datei.
Wenn ich auch nicht glaube, daß es daran liegt, denn die Parameter stimmen eigentlich und die Funktion "implode", die den Fehler (bzw. die Warnung) auslöst, ist schon ewig in PHP implementiert.

UploadPic sollte übrigens trotzdem funktionieren - wenn du einmal im ACP in der Config auf "speichern" klickst, werden die Datenbank-Werte auch angelegt ... würde allerdings trotzdem gerne rausfinden, wo der Fehler liegt.

Värmländer gab folgendes von sich:
Ähhh Embarassed , wie finde ich denn die Zeile 159?

Das ist die Zeile vor dieser hier:
Code:
   $message = sprintf($lang['Update_confirm'], implode(";\n\n", $sql));


____________
beehave - home of humbug ... [we can't afford to be neutral]

Nach oben
Private Nachricht senden Website dieses Benutzers besuchen Rang:godmode methusalem 3. platz professioneller Sportangler Profi-Winzer (7x Hamm) Arcade-Meister, Rang 16 rainbow-cup
Värmländer





Titel: (Kein Titel)
Verfasst am: Mo, 13 Feb 2006, 16:37
Beitrag
Antworten mit Zitat

Hallo nochmal!

Zitat:
PHP Version 4.3.10-16

http://www.vaermlaender.de/phpBB2/phpinfo.php


Zitat:
Für doch mal in die Install-Datei diese Zeile:
print_r($sql);
vor die Zeile 159 ein, mal sehen, was dann kommt. (Es sollte das Array mit den Datenbankänderungen ausgegeben werden.)


Hab ich gemacht.
Jetzt kommt folgende Fehlermeldung:

Zitat:
SELECT anzahl_posts FROM phpbb_nickpageconf
Warning: implode(): Bad arguments. in /var/kunden/webs/XXXXX/phpBB2/install/install_uploadpic.php on line 160


Wenn ich dann auf "JA" klicke, bekomme ich folgende Ausgabe:

Zitat:
Aktualisiere die Datenbank
S;

Fehler: You have an error in your SQL syntax. Check the manual that corresponds to your MySQL server version for the right syntax to use near 'S' at line 1
E;

Fehler: You have an error in your SQL syntax. Check the manual that corresponds to your MySQL server version for the right syntax to use near 'E' at line 1
L;

Fehler: You have an error in your SQL syntax. Check the manual that corresponds to your MySQL server version for the right syntax to use near 'L' at line 1
E;

Fehler: You have an error in your SQL syntax. Check the manual that corresponds to your MySQL server version for the right syntax to use near 'E' at line 1
C;

Fehler: You have an error in your SQL syntax. Check the manual that corresponds to your MySQL server version for the right syntax to use near 'C' at line 1
T;

Fehler: You have an error in your SQL syntax. Check the manual that corresponds to your MySQL server version for the right syntax to use near 'T' at line 1
;

Fehler: Query was empty
a;

Fehler: You have an error in your SQL syntax. Check the manual that corresponds to your MySQL server version for the right syntax to use near 'a' at line 1
n;

Fehler: You have an error in your SQL syntax. Check the manual that corresponds to your MySQL server version for the right syntax to use near 'n' at line 1
z;

Fehler: You have an error in your SQL syntax. Check the manual that corresponds to your MySQL server version for the right syntax to use near 'z' at line 1
a;

Fehler: You have an error in your SQL syntax. Check the manual that corresponds to your MySQL server version for the right syntax to use near 'a' at line 1
h;

Fehler: You have an error in your SQL syntax. Check the manual that corresponds to your MySQL server version for the right syntax to use near 'h' at line 1
l;

Fehler: You have an error in your SQL syntax. Check the manual that corresponds to your MySQL server version for the right syntax to use near 'l' at line 1
_;

Fehler: You have an error in your SQL syntax. Check the manual that corresponds to your MySQL server version for the right syntax to use near '_' at line 1
p;

Fehler: You have an error in your SQL syntax. Check the manual that corresponds to your MySQL server version for the right syntax to use near 'p' at line 1
o;

Fehler: You have an error in your SQL syntax. Check the manual that corresponds to your MySQL server version for the right syntax to use near 'o' at line 1
s;

Fehler: You have an error in your SQL syntax. Check the manual that corresponds to your MySQL server version for the right syntax to use near 's' at line 1
t;

Fehler: You have an error in your SQL syntax. Check the manual that corresponds to your MySQL server version for the right syntax to use near 't' at line 1
s;

Fehler: You have an error in your SQL syntax. Check the manual that corresponds to your MySQL server version for the right syntax to use near 's' at line 1
;

Fehler: Query was empty
F;

Fehler: You have an error in your SQL syntax. Check the manual that corresponds to your MySQL server version for the right syntax to use near 'F' at line 1
R;

Fehler: You have an error in your SQL syntax. Check the manual that corresponds to your MySQL server version for the right syntax to use near 'R' at line 1
O;

Fehler: You have an error in your SQL syntax. Check the manual that corresponds to your MySQL server version for the right syntax to use near 'O' at line 1
M;

Fehler: You have an error in your SQL syntax. Check the manual that corresponds to your MySQL server version for the right syntax to use near 'M' at line 1
;

Fehler: Query was empty
p;

Fehler: You have an error in your SQL syntax. Check the manual that corresponds to your MySQL server version for the right syntax to use near 'p' at line 1
h;

Fehler: You have an error in your SQL syntax. Check the manual that corresponds to your MySQL server version for the right syntax to use near 'h' at line 1


Installation komplett
Bitte lösche das install-Verzeichnis und diese Datei jetzt aus deinem Forum-Verzeichnis.

Hinweis: wenn andere Sprachen (außer englisch) installiert werden sollen, muß noch die entsprechende Datei im Verzeichnis "translations" ausgeführt werden !

Klick hier um zum Index zurückzukehren


LG
Andreas


Zuletzt bearbeitet von Värmländer am Di, 14 Feb 2006, 12:58, insgesamt einmal bearbeitet. (1 Prozent)

Nach oben
Rang:
boris



Beiträge: 10136

Titel: (Kein Titel)
Verfasst am: Mo, 13 Feb 2006, 19:03
Beitrag
Antworten mit Zitat

Värmländer @ Mo, 13 Feb 2006, 15:37 gab folgendes von sich:
PHP Version 4.3.10-16

Alles klar, damit kannst du die phpinfo.php schonmal wieder löschen.

Värmländer gab folgendes von sich:
Jetzt kommt folgende Fehlermeldung:
SELECT anzahl_posts FROM phpbb_nickpageconf (...)

Also ich weiß nicht, wie du es gemacht hast, aber das ist nicht, auf gar keinen Fall, unter keinen Umständen die UploadPic-Installdatei !!!!! Warte, noch ein paar Ausrufezeichen mehr: !!!!! big grin

1. hat gibt es in meiner Datei kein "SELECT"-Statement und
2. schon gar keine Abfrage der Tabelle phpbb_nickpageconf, die zum Nickpage-MOD gehört und mit UploadPic nicht das geringste zu tun hat

Värmländer gab folgendes von sich:
Wenn ich dann auf "JA" klicke, bekomme ich folgende Ausgabe:

Mehr als verständlich Cool

Wenn auch der letzte Satz der Meldung nahelegt, daß es sich um die UploadPic-Datei handelt, ist da irgendwas durcheinander gekommen - wie gesagt: ich habe nicht den blassesten Schimmer, wie du das geschafft hast.

Empfehlung: das Archiv nochmal ziehen, die Datei nochmal hochladen und dann nochmal ausführen.


____________
beehave - home of humbug ... [we can't afford to be neutral]

Nach oben
Private Nachricht senden Website dieses Benutzers besuchen Rang:godmode methusalem 3. platz professioneller Sportangler Profi-Winzer (7x Hamm) Arcade-Meister, Rang 16 rainbow-cup
Värmländer





Titel: (Kein Titel)
Verfasst am: Di, 14 Feb 2006, 12:49
Beitrag
Antworten mit Zitat

Hmmm, jetzt verstehe ich gar nix mehr.

Das hier ist das Installations-Script, welches ich bei dir runter geladen habe.
http://www.vaermlaender.de/phpBB2/install_uploadpic.txt

Liebe Grüße
Andreas

Nach oben
Rang:
Värmländer





Titel: (Kein Titel)
Verfasst am: Di, 14 Feb 2006, 13:30
Beitrag
Antworten mit Zitat

Ich nochmal Smile

Hab gerade versucht, die statusmail-install auszuführen.
Da bekomme ich eine ähnliche Fehlermeldung.
Zitat:
Warning: implode(): Bad arguments. in /var/kunden/webs/Nowak/phpBB2/install/db_update.php on line 132


Hab´ meinen Webhoster mal gebeten, diesen Thread hier zu lesen.
Vielleicht weiß er mehr.

LG
Andreas

Nach oben
Rang:
boris



Beiträge: 10136

Titel: (Kein Titel)
Verfasst am: Di, 14 Feb 2006, 14:01
Beitrag
Antworten mit Zitat

Värmländer @ Di, 14 Feb 2006, 11:49 gab folgendes von sich:
Das hier ist das Installations-Script, welches ich bei dir runter geladen habe.

Das sieht auch ok aus, und durchsuch das mal: da kommt nirgendwo ein "SELECT" oder sogar ein "nickpageconf" drin vor, daher muß vor dem Ausführen bei dir irgendwas damit passiert sein ! Irgendwas macht dir auf jeden Fall das Array $sql[] kaputt ...

Värmländer gab folgendes von sich:
Hab gerade versucht, die statusmail-install auszuführen. Da bekomme ich eine ähnliche Fehlermeldung.

"Technisch unmöglich" würde ich jetzt sagen ... confused4

Füg mal diesen Code:
echo '-<br>';
print_r($sql);
echo '<br>-<br>';

nach folgenden Zeilen ein:

1.
init_userprefs($userdata);

2.
// Build Array of SQL Statements.

3.
$sql = array();

4.
$sql_count = count($sql);


führ die Datei dann nochmal aus und poste das Ergebnis hier. (Klicken auf "ja" ist nicht erforderlich.)


____________
beehave - home of humbug ... [we can't afford to be neutral]

Nach oben
Private Nachricht senden Website dieses Benutzers besuchen Rang:godmode methusalem 3. platz professioneller Sportangler Profi-Winzer (7x Hamm) Arcade-Meister, Rang 16 rainbow-cup
Värmländer





Titel: (Kein Titel)
Verfasst am: Di, 14 Feb 2006, 18:32
Beitrag
Antworten mit Zitat

Hej Boris!

Jetzt bekomme ich folgende Meldung:

Zitat:
-
SELECT * FROM phpbb_shoutbox_config
-
-
SELECT * FROM phpbb_shoutbox_config
-
-
Array ( )
-
-
Array ( [0] => ALTER TABLE phpbb_users ADD user_allow_uploadpic TINYINT NOT NULL DEFAULT 0 [1] => UPDATE phpbb_users SET user_allow_uploadpic = 1 WHERE user_level = 1 [2] => INSERT INTO phpbb_config(config_name,config_value) VALUES('uploadpic_picdir','/phpBB2/userpix/') [3] => INSERT INTO phpbb_config(config_name,config_value) VALUES('uploadpic_uniqfn','1') [4] => INSERT INTO phpbb_config(config_name,config_value) VALUES('uploadpic_delete','1') [5] => INSERT INTO phpbb_config(config_name,config_value) VALUES('uploadpic_lrmod','0') [6] => INSERT INTO phpbb_config(config_name,config_value) VALUES('uploadpic_showlink','0') [7] => INSERT INTO phpbb_config(config_name,config_value) VALUES('uploadpic_vbbcode','0') [8] => INSERT INTO phpbb_config(config_name,config_value) VALUES('uploadpic_multiple','1') [9] => INSERT INTO phpbb_config(config_name,config_value) VALUES('uploadpic_maxsize','75') [10] => INSERT INTO phpbb_config(config_name,config_value) VALUES('uploadpic_maxpicx','550') [11] => INSERT INTO phpbb_config(config_name,config_value) VALUES('uploadpic_maxpicy','300') [12] => INSERT INTO phpbb_config(config_name,config_value) VALUES('uploadpic_minimum','15') [13] => INSERT INTO phpbb_config(config_name,config_value) VALUES('uploadpic_allowed','image/jpg|image/jpeg|image/pjpeg| image/gif|image/png|image/x-png|image/x-citrix-pjpeg') [14] => INSERT INTO phpbb_config(config_name,config_value) VALUES('uploadpic_jpgqual','80') [15] => INSERT INTO phpbb_config(config_name,config_value) VALUES('uploadpic_allowpm','1') [16] => INSERT INTO phpbb_config(config_name,config_value) VALUES('uploadpic_maxpmdays','30') [17] => INSERT INTO phpbb_config(config_name,config_value) VALUES('uploadpic_gallery','1') [18] => INSERT INTO phpbb_config(config_name,config_value) VALUES('uploadpic_gallerysize','250') [19] => INSERT INTO phpbb_config(config_name,config_value) VALUES('uploadpic_watermark','0') [20] => INSERT INTO phpbb_config(config_name,config_value) VALUES('uploadpic_wmpicture','images/up_watermark.png') [21] => INSERT INTO phpbb_config(config_name,config_value) VALUES('uploadpic_wmpicx','150') [22] => INSERT INTO phpbb_config(config_name,config_value) VALUES('uploadpic_wmpicy','150') [23] => INSERT INTO phpbb_config(config_name,config_value) VALUES('uploadpic_wmposition','6') [24] => INSERT INTO phpbb_config(config_name,config_value) VALUES('uploadpic_numlatest','10') [25] => INSERT INTO phpbb_config(config_name,config_value) VALUES('uploadpic_forcepath','') [26] => INSERT INTO phpbb_config(config_name,config_value) VALUES('uploadpic_minposts','0') )
-

Warning: Cannot modify header information - headers already sent by (output started at /var/kunden/webs/XXXXX/phpBB2/install/install_uploadpic.php:63) in /var/kunden/webs/XXXXX/phpBB2/includes/page_header.php on line 587

Warning: Cannot modify header information - headers already sent by (output started at /var/kunden/webs/XXXXX/phpBB2/install/install_uploadpic.php:63) in /var/kunden/webs/XXXXX/phpBB2/includes/page_header.php on line 593

Warning: Cannot modify header information - headers already sent by (output started at /var/kunden/webs/XXXXX/phpBB2/install/install_uploadpic.php:63) in /var/kunden/webs/XXXXX/phpBB2/includes/page_header.php on line 594

Warning: implode(): Bad arguments. in /var/kunden/webs/XXXXX/phpBB2/install/install_uploadpic.php on line 171


Sagt dir das etwas?

Liebe Grüße
Andreas

Nach oben
Rang:
boris



Beiträge: 10136

Titel: (Kein Titel)
Verfasst am: Di, 14 Feb 2006, 20:49
Beitrag
Antworten mit Zitat

Värmländer @ Di, 14 Feb 2006, 17:32 gab folgendes von sich:
Sagt dir das etwas?

Jo ... und zwar, daß mit dem Skript alles in Ordnung ist, der bei dir mit der implode-Funktion Probleme hat ... wäre ich nur bei meinem eigenen Install-Skript geblieben ... Sad


Also, jetzt wirds aufwändig - zum Testen der folgenden Sachen kannst du die Datei auch einem anderen Verzeichnis (z.B. "install_test") ausführen, dann musst du dafür nicht immer dein Forum sperren:

füge in der Original-Installdatei (!) dieses hier:
Code:
/*
VOR folgender Zeile ein:
$sql[] = 'UPDATE ' . USERS_TABLE . ' SET user_allow_uploadpic = 1 WHERE user_level = '.ADMIN;

und das hier:
Code:
*/
NACH dieser Zeile:
$sql[] = 'INSERT INTO ' . CONFIG_TABLE . '(config_name,config_value) VALUES(\'uploadpic_minposts\',\'0\')';

Damit werden bis auf den ersten Datenbank-Query alle anderen auskommentiert. Wenn jetzt die Fehlermeldung NICHT kommt, rückst du das "/*" eine Zeile tiefer, also hinter
$sql[] = 'UPDATE ' . USERS_TABLE . ' SET user_allow_uploadpic = 1 WHERE user_level = '.ADMIN;

wenns dann immer noch ohne Fehler geht, weiter hinter:
$sql[] = 'INSERT INTO ' . CONFIG_TABLE . '(config_name,config_value) VALUES(\'uploadpic_picdir\',\''.$str_updir.'\')';

(also die Leerzeile überspringen), bis du an die Stelle kommst, wo der Fehler wieder auftritt - WENN der dann auftritt, bräuchte ich von die die Zeile, die ÜBER dem "/*" steht, da muß dann irgendwas sein, was bei dir den Fehler verursacht.

Ich hoffe, das ist klar geworden - ich würds selber testen, aber bei mir läufts einwandfrei !


EDIT:
Achso, wenn der Fehler direkt beim ersten Mal immer noch auftaucht, kannst du dir die restlichen Schritte einfach sparen und Bescheid geben Smile


____________
beehave - home of humbug ... [we can't afford to be neutral]

Nach oben
Private Nachricht senden Website dieses Benutzers besuchen Rang:godmode methusalem 3. platz professioneller Sportangler Profi-Winzer (7x Hamm) Arcade-Meister, Rang 16 rainbow-cup
Värmländer





Titel: (Kein Titel)
Verfasst am: Di, 14 Feb 2006, 21:45
Beitrag
Antworten mit Zitat

Hej Boris!

Wenn ich die von dir genannten Zeichen an die von dir genannten Stellen
eingebe, erscheint:
Zitat:
S;

Fehler: You have an error in your SQL syntax. Check the manual that corresponds to your MySQL server version for the right syntax to use near 'S' at line 1


Wenn ich das /* eine Zeile tiefer setze kommt:
Zitat:
S;

Fehler: You have an error in your SQL syntax. Check the manual that corresponds to your MySQL server version for the right syntax to use near 'S' at line 1
E;

Fehler: You have an error in your SQL syntax. Check the manual that corresponds to your MySQL server version for the right syntax to use near 'E' at line 1


Noch eine Zeile tiefer =
Zitat:
S;

Fehler: You have an error in your SQL syntax. Check the manual that corresponds to your MySQL server version for the right syntax to use near 'S' at line 1
E;

Fehler: You have an error in your SQL syntax. Check the manual that corresponds to your MySQL server version for the right syntax to use near 'E' at line 1
L;

Fehler: You have an error in your SQL syntax. Check the manual that corresponds to your MySQL server version for the right syntax to use near 'L' at line 1


Dann:
Zitat:
S;

Fehler: You have an error in your SQL syntax. Check the manual that corresponds to your MySQL server version for the right syntax to use near 'S' at line 1
E;

Fehler: You have an error in your SQL syntax. Check the manual that corresponds to your MySQL server version for the right syntax to use near 'E' at line 1
L;

Fehler: You have an error in your SQL syntax. Check the manual that corresponds to your MySQL server version for the right syntax to use near 'L' at line 1
E;

Fehler: You have an error in your SQL syntax. Check the manual that corresponds to your MySQL server version for the right syntax to use near 'E' at line 1


usw usw.

LG
Andreas

Nach oben
Rang:
boris



Beiträge: 10136

Titel: (Kein Titel)
Verfasst am: Di, 14 Feb 2006, 21:53
Beitrag
Antworten mit Zitat

Und das schon auf der ersten Seite des Install-Skripts OHNE auf den Button zu klicken ???
Das ist wieder der Sch... mit der falschen Variable - der erste Test hat eigentlich gezeigt, daß die richtigen Abfragen ausgeführt werden müssten ...

... probiers mal hiermit:
beehave.de/inc/install_uploadpic.php.txt (alt, entfernt)


____________
beehave - home of humbug ... [we can't afford to be neutral]


Zuletzt bearbeitet von boris am Do, 19 März 2009, 12:12, insgesamt einmal bearbeitet. (1 Prozent)

Nach oben
Private Nachricht senden Website dieses Benutzers besuchen Rang:godmode methusalem 3. platz professioneller Sportangler Profi-Winzer (7x Hamm) Arcade-Meister, Rang 16 rainbow-cup
Värmländer





Titel: (Kein Titel)
Verfasst am: Di, 14 Feb 2006, 22:17
Beitrag
Antworten mit Zitat

Hej nochmal!

Doch doch!
Den "Ja"-Button habe ich geklickt.

Auf der ersten Seite kommt die selbe Fehlermeldung wie bereits im ersten
Thread beschrieben.

Bei deiner Datei das selbe.
Und beim klicken auf ja kommt
Code:
S;

Fehler: You have an error in your SQL syntax. Check the manual that corresponds to your MySQL server version for the right syntax to use near 'S' at line 1
E;

Fehler: You have an error in your SQL syntax. Check the manual that corresponds to your MySQL server version for the right syntax to use near 'E' at line 1


LG
Andreas

Nach oben
Rang:
boris



Beiträge: 10136

Titel: (Kein Titel)
Verfasst am: Di, 14 Feb 2006, 22:30
Beitrag
Antworten mit Zitat

Värmländer @ Di, 14 Feb 2006, 21:17 gab folgendes von sich:
Doch doch! Den "Ja"-Button habe ich geklickt.

shit_2 shit_2 ... siehe hier:

boris gab folgendes von sich:
führ die Datei dann nochmal aus und poste das Ergebnis hier. (Klicken auf "ja" ist nicht erforderlich.)

Ich muß wenigstens an der richtigen Stelle suchen können ...

Värmländer gab folgendes von sich:
Auf der ersten Seite kommt die selbe Fehlermeldung wie bereits im ersten Thread beschrieben.

Also der "implode"-Fehler ?? DER muss erstmal behoben werden ... wenn du mit nem fehlerhaften Skript startest, kannst du nicht erwarten, daß plötzlich auf der zweiten Seite alles funktioniert.

Värmländer gab folgendes von sich:
Bei deiner Datei das selbe.

Probier nochmal die
beehave.de/inc/install_uploadpic.php.txt (alt, entfernt)
OHNE Klicken auf "ja" ... hab die nochmal geändert - wenns dann immer noch nicht geht, weiß ichs nicht, irgendwas ist bei dir auf jeden Fall anders - ich habs hier mehrfach probiert, es geht einwandfrei !


____________
beehave - home of humbug ... [we can't afford to be neutral]


Zuletzt bearbeitet von boris am Do, 19 März 2009, 12:13, insgesamt einmal bearbeitet. (1 Prozent)

Nach oben
Private Nachricht senden Website dieses Benutzers besuchen Rang:godmode methusalem 3. platz professioneller Sportangler Profi-Winzer (7x Hamm) Arcade-Meister, Rang 16 rainbow-cup
Värmländer





Titel: (Kein Titel)
Verfasst am: Di, 14 Feb 2006, 22:50
Beitrag
Antworten mit Zitat

Es tut sich etwas Smile

Seite 1 =
Zitat:
Dieses Skript wird die Datenbank mit den unten aufgeführten SQL-Statements aktualisieren.

Vor dem Ausführen sollte ein Backup der Datenbank angefertigt werden!
--------------------------------------------------------------------------- -----
ALTER TABLE phpbb_users ADD user_allow_uploadpic TINYINT NOT NULL DEFAULT 0;

UPDATE phpbb_users SET user_allow_uploadpic = 1 WHERE user_level = 1;

INSERT INTO phpbb_config(config_name,config_value) VALUES('uploadpic_picdir','/phpBB2/userpix/');

INSERT INTO phpbb_config(config_name,config_value) VALUES('uploadpic_uniqfn','1');

INSERT INTO phpbb_config(config_name,config_value) VALUES('uploadpic_delete','1');

INSERT INTO phpbb_config(config_name,config_value) VALUES('uploadpic_lrmod','0');

INSERT INTO phpbb_config(config_name,config_value) VALUES('uploadpic_showlink','0');

INSERT INTO phpbb_config(config_name,config_value) VALUES('uploadpic_vbbcode','0');

INSERT INTO phpbb_config(config_name,config_value) VALUES('uploadpic_multiple','1');

INSERT INTO phpbb_config(config_name,config_value) VALUES('uploadpic_maxsize','75');

INSERT INTO phpbb_config(config_name,config_value) VALUES('uploadpic_maxpicx','550');

INSERT INTO phpbb_config(config_name,config_value) VALUES('uploadpic_maxpicy','300');

INSERT INTO phpbb_config(config_name,config_value) VALUES('uploadpic_minimum','15');

INSERT INTO phpbb_config(config_name,config_value) VALUES('uploadpic_allowed','image/jpg|image/jpeg|image/pjpeg|image/gif|i mage/png|image/x-png|image/x-citrix-pjpeg');

INSERT INTO phpbb_config(config_name,config_value) VALUES('uploadpic_jpgqual','80');

INSERT INTO phpbb_config(config_name,config_value) VALUES('uploadpic_allowpm','1');

INSERT INTO phpbb_config(config_name,config_value) VALUES('uploadpic_maxpmdays','30');

INSERT INTO phpbb_config(config_name,config_value) VALUES('uploadpic_gallery','1');

INSERT INTO phpbb_config(config_name,config_value) VALUES('uploadpic_gallerysize','250');

INSERT INTO phpbb_config(config_name,config_value) VALUES('uploadpic_watermark','0');

INSERT INTO phpbb_config(config_name,config_value) VALUES('uploadpic_wmpicture','images/up_watermark.png');

INSERT INTO phpbb_config(config_name,config_value) VALUES('uploadpic_wmpicx','150');

INSERT INTO phpbb_config(config_name,config_value) VALUES('uploadpic_wmpicy','150');

INSERT INTO phpbb_config(config_name,config_value) VALUES('uploadpic_wmposition','6');

INSERT INTO phpbb_config(config_name,config_value) VALUES('uploadpic_numlatest','10');

INSERT INTO phpbb_config(config_name,config_value) VALUES('uploadpic_forcepath','');

INSERT INTO phpbb_config(config_name,config_value) VALUES('uploadpic_minposts','0')


--------------------------------------------------------------------------- -----
Klicke Ja um fortzufahren oder Nein, um zum Forum-Index zurückzukehren.

Hinweis: Wenn das Forum auf einem Windows-Server läuft, sind u.U. die Schreibberechtigungen für das userpix-Verzeichnis manuell zu setzen.



Soll ich jetzt den Ja-Button klicken?

Liebe Grüße und Danke für deine Mühe, die du dir machst.
Andreas

Nach oben
Rang:
boris



Beiträge: 10136

Titel: (Kein Titel)
Verfasst am: Di, 14 Feb 2006, 22:53
Beitrag
Antworten mit Zitat

Värmländer @ Di, 14 Feb 2006, 21:50 gab folgendes von sich:
Soll ich jetzt den Ja-Button klicken?

Das halte ich jetzt für eine gute Idee Smile
Auf der nächsten Seite wirst du zwar auch ein paar Fehler bekommen (meist "Duplicate entry"), die sind aber normal ... damit sollte die Sache erledigt sein.


____________
beehave - home of humbug ... [we can't afford to be neutral]

Nach oben
Private Nachricht senden Website dieses Benutzers besuchen Rang:godmode methusalem 3. platz professioneller Sportangler Profi-Winzer (7x Hamm) Arcade-Meister, Rang 16 rainbow-cup
Värmländer





Titel: (Kein Titel)
Verfasst am: Di, 14 Feb 2006, 23:09
Beitrag
Antworten mit Zitat

Jaaaaa!

Es funktioniert

Super! Dankeschön.

Hier die Meldung:
Zitat:
Aktualisiere die Datenbank
ALTER TABLE phpbb_users ADD user_allow_uploadpic TINYINT NOT NULL DEFAULT 0;

Fehler: Duplicate column name 'user_allow_uploadpic'
UPDATE phpbb_users SET user_allow_uploadpic = 1 WHERE user_level = 1;

erfolgreich
INSERT INTO phpbb_config(config_name,config_value) VALUES('uploadpic_picdir','/phpBB2/userpix/');

Fehler: Duplicate entry 'uploadpic_picdir' for key 1
INSERT INTO phpbb_config(config_name,config_value) VALUES('uploadpic_uniqfn','1');

Fehler: Duplicate entry 'uploadpic_uniqfn' for key 1
INSERT INTO phpbb_config(config_name,config_value) VALUES('uploadpic_delete','1');

Fehler: Duplicate entry 'uploadpic_delete' for key 1
INSERT INTO phpbb_config(config_name,config_value) VALUES('uploadpic_lrmod','0');

Fehler: Duplicate entry 'uploadpic_lrmod' for key 1
INSERT INTO phpbb_config(config_name,config_value) VALUES('uploadpic_showlink','0');

Fehler: Duplicate entry 'uploadpic_showlink' for key 1
INSERT INTO phpbb_config(config_name,config_value) VALUES('uploadpic_vbbcode','0');

Fehler: Duplicate entry 'uploadpic_vbbcode' for key 1
INSERT INTO phpbb_config(config_name,config_value) VALUES('uploadpic_multiple','1');

Fehler: Duplicate entry 'uploadpic_multiple' for key 1
INSERT INTO phpbb_config(config_name,config_value) VALUES('uploadpic_maxsize','75');

Fehler: Duplicate entry 'uploadpic_maxsize' for key 1
INSERT INTO phpbb_config(config_name,config_value) VALUES('uploadpic_maxpicx','550');

Fehler: Duplicate entry 'uploadpic_maxpicx' for key 1
INSERT INTO phpbb_config(config_name,config_value) VALUES('uploadpic_maxpicy','300');

Fehler: Duplicate entry 'uploadpic_maxpicy' for key 1
INSERT INTO phpbb_config(config_name,config_value) VALUES('uploadpic_minimum','15');

Fehler: Duplicate entry 'uploadpic_minimum' for key 1
INSERT INTO phpbb_config(config_name,config_value) VALUES('uploadpic_allowed','image/jpg|image/jpeg|image/pjpeg|image/gif|i mage/png|image/x-png|image/x-citrix-pjpeg');

Fehler: Duplicate entry 'uploadpic_allowed' for key 1
INSERT INTO phpbb_config(config_name,config_value) VALUES('uploadpic_jpgqual','80');

Fehler: Duplicate entry 'uploadpic_jpgqual' for key 1
INSERT INTO phpbb_config(config_name,config_value) VALUES('uploadpic_allowpm','1');

Fehler: Duplicate entry 'uploadpic_allowpm' for key 1
INSERT INTO phpbb_config(config_name,config_value) VALUES('uploadpic_maxpmdays','30');

Fehler: Duplicate entry 'uploadpic_maxpmdays' for key 1
INSERT INTO phpbb_config(config_name,config_value) VALUES('uploadpic_gallery','1');

Fehler: Duplicate entry 'uploadpic_gallery' for key 1
INSERT INTO phpbb_config(config_name,config_value) VALUES('uploadpic_gallerysize','250');

Fehler: Duplicate entry 'uploadpic_gallerysize' for key 1
INSERT INTO phpbb_config(config_name,config_value) VALUES('uploadpic_watermark','0');

Fehler: Duplicate entry 'uploadpic_watermark' for key 1
INSERT INTO phpbb_config(config_name,config_value) VALUES('uploadpic_wmpicture','images/up_watermark.png');

Fehler: Duplicate entry 'uploadpic_wmpicture' for key 1
INSERT INTO phpbb_config(config_name,config_value) VALUES('uploadpic_wmpicx','150');

Fehler: Duplicate entry 'uploadpic_wmpicx' for key 1
INSERT INTO phpbb_config(config_name,config_value) VALUES('uploadpic_wmpicy','150');

Fehler: Duplicate entry 'uploadpic_wmpicy' for key 1
INSERT INTO phpbb_config(config_name,config_value) VALUES('uploadpic_wmposition','6');

Fehler: Duplicate entry 'uploadpic_wmposition' for key 1
INSERT INTO phpbb_config(config_name,config_value) VALUES('uploadpic_numlatest','10');

Fehler: Duplicate entry 'uploadpic_numlatest' for key 1
INSERT INTO phpbb_config(config_name,config_value) VALUES('uploadpic_forcepath','');

Fehler: Duplicate entry 'uploadpic_forcepath' for key 1
INSERT INTO phpbb_config(config_name,config_value) VALUES('uploadpic_minposts','0');

Fehler: Duplicate entry 'uploadpic_minposts' for key 1




Und jetzt das ganze nochmal für die Status-Mail Embarassed

Liebe Grüße nach Köln und nochmals ein dickes Dankeschön
Andreas

PS.
Ist es schwierig zu erklären, woran es lag?

Nach oben
Rang:
boris



Beiträge: 10136

Titel: (Kein Titel)
Verfasst am: Di, 14 Feb 2006, 23:54
Beitrag
Antworten mit Zitat

Värmländer @ Di, 14 Feb 2006, 22:09 gab folgendes von sich:
Und jetzt das ganze nochmal für die Status-Mail Embarassed

Da wirst du dann auch eine geänderte Version brauchen:
beehave.de/inc/db_update.php.txt (alt, entfernt)

Värmländer gab folgendes von sich:
Liebe Grüße nach Köln und nochmals ein dickes Dankeschön

Jo ... und der übliche Spruch: mail mir n Bier :biggrin:

Värmländer gab folgendes von sich:
Ist es schwierig zu erklären, woran es lag?

Sehr! Weil ichs nicht weiß ... Smile
Irgend ein anderes Skript bei dir (zuerst wars nickpage, dann shoutbox) hat die Variablen in dem Installskript durcheinander gebracht - WIE das gehen soll, ist mir total schleierhaft, aber die Variable $sql hatte ständig den falschen Inhalt. Nach dem Umbenennen in $sqlneu konnte keiner mehr dazwischenfunken und offensichtlich gings dann ...


____________
beehave - home of humbug ... [we can't afford to be neutral]

Nach oben
Private Nachricht senden Website dieses Benutzers besuchen Rang:godmode methusalem 3. platz professioneller Sportangler Profi-Winzer (7x Hamm) Arcade-Meister, Rang 16 rainbow-cup
Beiträge der letzten Zeit anzeigen:   
Neues Thema eröffnen   Neue Antwort erstellen    beeForum Foren-übersicht » hal9000 » mod support Seite 1 von 1
Gehe zu:  



ähnliche Beiträge
Thema Autor Forum Antworten Verfasst am
Keine neuen Beiträge Error message: "Please make sure the install an... mainicia mod support 1 Mo, 09 Jul 2007, 11:20 Letzten Beitrag anzeigen
Keine neuen Beiträge upload picture hack install problems wijcc mod support 2 Mi, 13 Jun 2007, 17:46 Letzten Beitrag anzeigen
Keine neuen Beiträge Fehlermeldung caboclo werkstatt 1 Mo, 14 Mai 2007, 10:30 Letzten Beitrag anzeigen
Keine neuen Beiträge ich kann das Install-Skript nicht ausführen boris mod support 2 Do, 10 Mai 2007, 16:19 Letzten Beitrag anzeigen
Keine neuen Beiträge Error in SQL install !! shorbaji mod support 1 Fr, 23 Feb 2007, 20:29 Letzten Beitrag anzeigen


Schreiben: nein. Antworten: nein. Bearbeiten: nein. Löschen: nein. Umfragen: nein.
phpBB © phpBB Group | impressum