Benutzername    Passwort    Autologin    
  Passwort vergessen       Registrieren  
beeForum Foren-übersicht » hal9000 » mod support
Neues Thema eröffnen   Neue Antwort erstellen Hervorhebung entfernen


So ganz läuft es noch nicht...
Vorheriges Thema anzeigen :: Nächstes Thema anzeigen  
Autor Nachricht
ttahl





Titel: So ganz läuft es noch nicht...
Verfasst am: Mi, 19 Apr 2006, 00:24
Beitrag
Antworten mit Zitat

Hallo,

erstmal ein dickes Kompliment an der Pogrammer. Ein echt netter MOD!

Habe ihn gerade installiert. Es wurden auch die Mails verschickt, da wurde mir zumindest angezeigt.

Jedoch treten noch ein paar Fehler auf.

Code:

Warning: main(./language/lang_hebrew/lang_main.php): failed to open stream: No such file or directory in /xyz/forum/includes/statusmail.php on line 175

Warning: main(./language/lang_hebrew/lang_main.php): failed to open stream: No such file or directory in /xyz/forum/includes/statusmail.php on line 175

Warning: main(): Failed opening './language/lang_hebrew/lang_main.php' for inclusion (include_path='.:/usr/local/lib/php') in /xyz/forum/includes/statusmail.php on line 175

Warning: main(./language/lang_spanish/lang_main.php): failed to open stream: No such file or directory in /xyz/forum/includes/statusmail.php on line 175

Warning: main(./language/lang_spanish/lang_main.php): failed to open stream: No such file or directory in /xyz/forum/includes/statusmail.php on line 175

Warning: main(): Failed opening './language/lang_spanish/lang_main.php' for inclusion (include_path='.:/usr/local/lib/php') in /xyz/forum/includes/statusmail.php on line 175

Warning: Cannot modify header information - headers already sent by (output started at /xyz/forum/includes/statusmail.php:175) in /xyzforum/includes/page_header.php on line 715

Warning: Cannot modify header information - headers already sent by (output started at /xyz/forum/includes/statusmail.php:175) in /xyz/forum/includes/page_header.php on line 717

Warning: Cannot modify header information - headers already sent by (output started at /xyz/forum/includes/statusmail.php:175) in /xyz/forum/includes/page_header.php on line 718


Was soll ich davon halten?

In line 175 steht bei mit folgendes
Code:
   include($phpbb_root_path.'language/lang_'.$row['user_lang'].'/lang_main.'.$phpEx);


Heißt das etwas, dass ein paar User bei mir hebräisch und spanisch als Sprache gewählt haben und die Mail in dieser Sprache nicht verschickt werden können, da dort in den language Verzeichnissen nicht die nötigen Dateien drin sind?

Doch was sind die Fehler in der page_header.php ?

BTW: Das ausführen der db_update.php hat irgendwie nicht funktioniert.
Jedefalls wurde die SQL-Befehle nicht abgearbeitet. Ich habe immer nur die Meldung bekommen, dass das Forum gesperrt ist. Habe dann die Befehle manuell eingegeben.

Nach oben
Rang:
boris



Beiträge: 10136

Titel: Re: So ganz läuft es noch nicht...
Verfasst am: Mi, 19 Apr 2006, 10:19
Beitrag
Antworten mit Zitat

ttahl @ Mi, 19 Apr 2006, 00:24 gab folgendes von sich:
Heißt das etwas, dass ein paar User bei mir hebräisch und spanisch als Sprache gewählt haben und die Mail in dieser Sprache nicht verschickt werden können, da dort in den language Verzeichnissen nicht die nötigen Dateien drin sind?

Das hätte ich nicht besser ausdrücken können, genau das heißt es big grin

Bevor ich jetzt aber anfange, dafür einen Check zu programmieren, der den Versand verlangsamen würde (es wird nach Sprachen sortiert, damit pro Sprache die Sprachdatei nur einmal inkludiert werden muß), solltest du eher versuchen, dein Forum zu "reparieren" Cool

ttahl gab folgendes von sich:
Doch was sind die Fehler in der page_header.php ?

Die kannst du ignorieren - da eine Fehlermeldung ausgegeben wurde, sagt das Session-Management von PHP: "Moment mal, vor mir darf nichts anderes ausgegeben werden" und motzt. Sobald der Sprachfehler weg ist, verschwindet die Meldung von selbst.

ttahl gab folgendes von sich:
Jedefalls wurde die SQL-Befehle nicht abgearbeitet. Ich habe immer nur die Meldung bekommen, dass das Forum gesperrt ist.

Dann wird das wahrscheinlich stimmen (wie auch immer, kenne die Meldung nicht) - auf jeden Fall läßt sich das Installskript sonst immer fehlerfrei ausführen, das ist ein phpbb.com-Standardskript, das muß funktionieren, wenn das Forum richtig konfiguriert ist.


____________
beehave - home of humbug ... [we can't afford to be neutral]

Nach oben
Private Nachricht senden Website dieses Benutzers besuchen Rang:godmode methusalem 3. platz professioneller Sportangler Profi-Winzer (7x Hamm) Arcade-Meister, Rang 16 rainbow-cup
ttahl





Titel: (Kein Titel)
Verfasst am: Mi, 19 Apr 2006, 10:37
Beitrag
Antworten mit Zitat

Zitat:
.....solltest du eher versuchen, dein Forum zu "reparieren"


Naja, ich habe jetzt alle Sprachen außer Englisch und Deutsch gelöscht. Das sind sowieso nur die Sprachen, die "gewartet" werden. Jetzt sollte es laufen.

Zu dem "fehlerhaften" Datenbankupdate. Naja, das Forum hatte ich wirklich gesperrt. Deshalb ging das Script nicht. Jetzt funktioniert es.

Noch ein kleiner Hinweis.
Bei meinem GMX Account ist die Statusmail direkt im Spamordner gelandet. Der Breifkopf sieht lauf GMX wohl nach Spam aus.

Werde aber die tpl- Dateien noch verändern.

Nach oben
Rang:
boris



Beiträge: 10136

Titel: (Kein Titel)
Verfasst am: Mi, 19 Apr 2006, 11:18
Beitrag
Antworten mit Zitat

ttahl @ Mi, 19 Apr 2006, 10:37 gab folgendes von sich:
Bei meinem GMX Account ist die Statusmail direkt im Spamordner gelandet. Der Breifkopf sieht lauf GMX wohl nach Spam aus.
Werde aber die tpl- Dateien noch verändern.

Das wird m.E. nach nicht viel bringen, da phpBB den Kopf der Nachricht erzeugt, und die sieht bei allen Mails von dem Forum gleich aus.

Ich weiß nicht, wie der GMX-Spamfilter funktioniert, bei web.de und bei Googlemail ist das aber so, daß eine Mail eher als Spam klassifiziert wird, je mehr Leute die Mail dafür halten. Wenn du also viele Leute hast, die die StatusMail als Spam wegklicken, statt die abzubestellen, kannst du da nichts gegen machen.

Auch liegt es in der Natur der StatusMail, daß die relativ viele Links enthält (u.U. zusätzlich noch mehr HTML), was auch immer ein Spamkriterium sein kann. Die Mails als Textmail mit einer hohen Anzahl an Zeichen für die Vorschau könnte das Problem mindern, muß aber nicht.


____________
beehave - home of humbug ... [we can't afford to be neutral]

Nach oben
Private Nachricht senden Website dieses Benutzers besuchen Rang:godmode methusalem 3. platz professioneller Sportangler Profi-Winzer (7x Hamm) Arcade-Meister, Rang 16 rainbow-cup
ttahl





Titel: (Kein Titel)
Verfasst am: Mi, 19 Apr 2006, 11:35
Beitrag
Antworten mit Zitat

Hier mal ein Text zu der Spamerkennung von GMX. Bei mir wurde die Mail als Spam eingestuft, weil der Briefkopf verdächtig war.

Zitat:
H = Briefkopf-Analyzer

Dieses AntiSpam-Tool auf der Basis von "Spamassassin" nimmt den so genannten "Header" der E-Mails unter die Lupe. Der Header einer E-Mail enthält den Absender, Empfänger und Betreff, aber auch Informationen darüber, auf welchem virtuellen Weg die E-Mail den Empfänger erreicht hat, welchen E-Mail-Client der Absender verwendet hat und an welche Adresse eventuelle Antworten zugestellt werden sollen. Einige dieser Angaben werden von Spam-Versendern oftmals mit der Absicht verfälscht, eine "normale", erwünschte E-Mail vorzutäuschen. Der Briefkopf-Analyzer kennt diese Tricks der Spammer und überprüft jedes einzelne Element der Header-Informationen genau. Ähnlich wie beim Textmuster-Profiler werden den einzelnen analysierten Merkmalen Werte zugeordnet, je nachdem wie typisch sie für eine Spam-Mail sind. Aus diesen Werten wird wiederum ein Wahrscheinlichkeitswert errechnet.In den AntiSpam-Optionen können Sie selbst festlegen, wie "empfindlich" der Briefkopf-Analyzer auf Spam-Anzeichen reagieren soll. Wird diese Einstellung auf "hohe Empfindlichkeit" gesetzt, so bedeutet das, dass schon eine geringe Wahrscheinlichkeit – also wenige typische Merkmale - zum Ausfiltern der E-Mail führt.Wenn Sie sich den Header einer aussortierten E-Mail anzeigen lassen, können Sie selbst nachvollziehen, warum der Briefkopf-Analyzer die E-Mail als Spam eingestuft hat: Im Header selbst werden an den entsprechenden Stellen die Namen der Tests ausgegeben, die ein Spam-Merkmal ergeben haben.


Eine Testmail, die ich vor zwei Tagen über dsa Board verschickt habe, wurde nich als Spam eingestuft.

Jedenfalls bin ich bisher mit dem MOD sehr zufrieden. Ich wüsste nicht, was man da noch verbessern sollte.

Nach oben
Rang:
boris



Beiträge: 10136

Titel: (Kein Titel)
Verfasst am: Mi, 19 Apr 2006, 12:01
Beitrag
Antworten mit Zitat

GMX gab folgendes von sich:
Wenn Sie sich den Header einer aussortierten E-Mail anzeigen lassen, können Sie selbst nachvollziehen, warum der Briefkopf-Analyzer die E-Mail als Spam eingestuft hat: Im Header selbst werden an den entsprechenden Stellen die Namen der Tests ausgegeben, die ein Spam-Merkmal ergeben haben.

Kuck da doch mal nach, dann kann man die Suche wenigstens eingrenzen ...

ttahl gab folgendes von sich:
Jedenfalls bin ich bisher mit dem MOD sehr zufrieden. Ich wüsste nicht, was man da noch verbessern sollte.

Hauptsache big grin


____________
beehave - home of humbug ... [we can't afford to be neutral]

Nach oben
Private Nachricht senden Website dieses Benutzers besuchen Rang:godmode methusalem 3. platz professioneller Sportangler Profi-Winzer (7x Hamm) Arcade-Meister, Rang 16 rainbow-cup
ttahl





Titel: (Kein Titel)
Verfasst am: Mi, 19 Apr 2006, 12:37
Beitrag
Antworten mit Zitat

Habe mal nachgeschaut. Da treffen mehrer Komponenten zu

Zitat:
X-GMX-Antispam: 5 (Score=2.455; MIME_HTML_ONLY NO_REAL_NAME POSSIBLE_DIALUP_3 MISSING_OUTLOOK_NAME)


Also
MIME_HTML_ONLY
NO_REAL_NAME
POSSIBLE_DIALUP_3
MISSING_OUTLOOK_NAME

Vielleicht kann man das einen oder andere Kriterium noch beseitigen.

Nach oben
Rang:
boris



Beiträge: 10136

Titel: (Kein Titel)
Verfasst am: Mi, 19 Apr 2006, 12:53
Beitrag
Antworten mit Zitat

ttahl @ Mi, 19 Apr 2006, 12:37 gab folgendes von sich:
MIME_HTML_ONLY

Ist klar, da die phpBB-Mailing-Funktion normalerweise nur Textmails verschickt, ist beim Umstellen auf HTML dann nur HTML vorhanden. Um das zu beheben und HTML und Text zu verschicken, müßte die komplette Mailfunktion aufgebohrt (wenn nicht sogar komplett überarbeitet) werden - dazu fühle ich mich nicht wirklich berufen big grin
Einzige Abhilfe dürfte sein, daß du überall Textmails einstellst. Wer sich als User dann HTML zuschicken lassen will, muß er halt dafür sorgen, daß er die Mail aus dem Spamordner fischt.

ttahl gab folgendes von sich:
NO_REAL_NAME

Müßte ich mal nachsehen, ob das in StatusMail eingetragen werden kann ...

ttahl gab folgendes von sich:
POSSIBLE_DIALUP_3

Taucht - laut Google - auf, wenn dein Server kein Reverse-DNS-Lookup aktiviert hat, muß der Administrator des Servers für die Domain einrichten, soweit ich weiß, bin da aber auch kein Experte.

ttahl gab folgendes von sich:
MISSING_OUTLOOK_NAME

Könnte sich um einen Bug in SpamAssassin handeln (s. z.B. hier), kann ich nichts zu sagen, vor allem, da Outlook mit StatusMail überhaupt nichts zu tun hat.


____________
beehave - home of humbug ... [we can't afford to be neutral]


Zuletzt bearbeitet von boris am Sa, 06 Sep 2008, 09:15, insgesamt einmal bearbeitet. (1 Prozent)

Nach oben
Private Nachricht senden Website dieses Benutzers besuchen Rang:godmode methusalem 3. platz professioneller Sportangler Profi-Winzer (7x Hamm) Arcade-Meister, Rang 16 rainbow-cup
ttahl





Titel: (Kein Titel)
Verfasst am: Mi, 19 Apr 2006, 13:20
Beitrag
Antworten mit Zitat

Ok,

es scheint aber an meiner Konfiguration zu liegen, denn ich bekomme aus einem anderen Forum eine Statusmail, die nicht als Spam eingestuft wird.

Zitat:
X-GMX-Antispam: 0 (Mail was not recognized as spam)


Die Unterschiede sind. Bei mir ist der Return-Path ein anderer als die E-Mail ID des Senders. Außerdem wird bei mir die Mail vom Apache Server verschickt, bei der anderen Mail läuft alles über einen SMTP-Server.

Der Content-Type ist bei beiden Mails "Content-type: text/html; charset=iso-8859-1"

Stelle ich aber im ACP Die Option "Nutze einen SMTP Server zum Mailen" auf "Ja" dann bekomme ich immer die Meldung "0 Statusmails verschickt", aber keine Fehlermeldung. Dürfte das sein, oder sollte nicht immer eine Statusmail an die User raus gehen, wenn ich den Befehl ww.xyz.de/forum/index.php?sendall=CODEWORT ausführe?!?!

Will jetzt auch nicht all zu viel probieren, da sonst die User wirklich zugespammt werden.

Nach oben
Rang:
boris



Beiträge: 10136

Titel: (Kein Titel)
Verfasst am: Mi, 19 Apr 2006, 13:36
Beitrag
Antworten mit Zitat

ttahl @ Mi, 19 Apr 2006, 13:20 gab folgendes von sich:
sollte nicht immer eine Statusmail an die User raus gehen, wenn ich den Befehl ww.xyz.de/forum/index.php?sendall=CODEWORT ausführe?!?!

Auf gar keinen Fall !

Hier habe ich schonmal genau beschrieben, wie das abläuft. Es bekommt immer nur der eine Mail, für den es neue Nachrichten gibt und dessen Intervall noch nicht abgelaufen ist !

Wenn du also testen willst, müßtest du bei einem Account (deinem z.B.) in der Datenbank in der Tabelle phpbb_users das Feld statusmail_last ändern, damit du wieder "fällig" für eine neue StatusMail bist und eine Mail verschickt wird.


____________
beehave - home of humbug ... [we can't afford to be neutral]

Nach oben
Private Nachricht senden Website dieses Benutzers besuchen Rang:godmode methusalem 3. platz professioneller Sportangler Profi-Winzer (7x Hamm) Arcade-Meister, Rang 16 rainbow-cup
ttahl





Titel: (Kein Titel)
Verfasst am: Do, 20 Apr 2006, 09:08
Beitrag
Antworten mit Zitat

Mhh,

jetzt wurden die Mails über den SMTP Server versendet. Leider mit dem gleichen Ergebnis.

Das verstehe ich nicht, denn die Statusmail aus dem anderen Forum wird auch als HTML versendet. Doch dort tauch der Begriff "MIME_HTML_ONLY" nicht im Header auf.

Nach oben
Rang:
boris



Beiträge: 10136

Titel: (Kein Titel)
Verfasst am: Do, 20 Apr 2006, 09:39
Beitrag
Antworten mit Zitat

ttahl @ Do, 20 Apr 2006, 09:08 gab folgendes von sich:
Das verstehe ich nicht, denn die Statusmail aus dem anderen Forum wird auch als HTML versendet. Doch dort tauch der Begriff "MIME_HTML_ONLY" nicht im Header auf.

Da bin ich jetzt leider auch überfragt ... vielleicht mal bei dem Typen nachhorchen, was der u.U. für andere Einstellungen hat ?


____________
beehave - home of humbug ... [we can't afford to be neutral]

Nach oben
Private Nachricht senden Website dieses Benutzers besuchen Rang:godmode methusalem 3. platz professioneller Sportangler Profi-Winzer (7x Hamm) Arcade-Meister, Rang 16 rainbow-cup
ttahl





Titel: (Kein Titel)
Verfasst am: Do, 20 Apr 2006, 09:42
Beitrag
Antworten mit Zitat

Zitat:
vielleicht mal bei dem Typen nachhorchen, was der u.U. für andere Einstellungen hat ?


Schon gemacht.
Wenn er aber die gleichen Einstellungen verwendet wie ich.... Evil or Very Mad

Nach oben
Rang:
boris



Beiträge: 10136

Titel: (Kein Titel)
Verfasst am: Do, 20 Apr 2006, 09:46
Beitrag
Antworten mit Zitat

ttahl @ Do, 20 Apr 2006, 09:42 gab folgendes von sich:
Wenn er aber die gleichen Einstellungen verwendet wie ich.... Evil or Very Mad

Dann weiss ich auch nicht mehr weiter ...

Ein Spamfaktor ist aber immer noch, daß dein Server kein Reverse-DNS-Lookup zuläßt ... vielleicht ist es so, daß der Spamfilter bei Servern, bei denen dieser Punkt OK ist, garnicht erst weiter nach anderen Spamkritierien sucht und nur bei "verdächtigen" Servern (wie deinem) dann das volle Programm ausfährt.


____________
beehave - home of humbug ... [we can't afford to be neutral]

Nach oben
Private Nachricht senden Website dieses Benutzers besuchen Rang:godmode methusalem 3. platz professioneller Sportangler Profi-Winzer (7x Hamm) Arcade-Meister, Rang 16 rainbow-cup
Beiträge der letzten Zeit anzeigen:   
Neues Thema eröffnen   Neue Antwort erstellen    beeForum Foren-übersicht » hal9000 » mod support Seite 1 von 1
Gehe zu:  



ähnliche Beiträge
Thema Autor Forum Antworten Verfasst am
Keine neuen Beiträge Wiglaf Droste - Sprichst du noch oder kommunizierst ... boris kühnes mittelscharfer 0 Mo, 09 Sep 2019, 11:17 Letzten Beitrag anzeigen
Keine neuen Beiträge Film: Remember - Vergiss nicht, dich zu erinnern boris zelluloid 0 Mi, 19 Dez 2018, 21:22 Letzten Beitrag anzeigen
Keine neuen Beiträge Film: Shrink - Nur nicht die Nerven verlieren boris zelluloid 0 Sa, 04 März 2017, 12:46 Letzten Beitrag anzeigen
Keine neuen Beiträge Roald Dahl - Ich sehe was, was du nicht siehst boris kühnes mittelscharfer 0 Sa, 04 März 2017, 12:36 Letzten Beitrag anzeigen
Keine neuen Beiträge Raymond Carver - Warum tanzt ihr nicht boris kühnes mittelscharfer 0 Di, 03 Jan 2017, 22:01 Letzten Beitrag anzeigen


Schreiben: nein. Antworten: nein. Bearbeiten: nein. Löschen: nein. Umfragen: nein.
phpBB © phpBB Group | impressum